Ski-Doo Snowmobiles Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
396 Posts
Discussion Starter · #1 ·
I'm at the tail end of a sled over haul and when i got to the oil reservoir i found that i have what looks and feels like sometype of gel. Little chunks all over the place. I only use good BRP oil in the sled. Its stuck to the inside walls of the reservoir. both carb and brake fluid does little to clean it off. Is this stuff bad? I would think it would just clog up my filter and i would never know till the damage was done. ?????
 

·
Registered
Joined
·
1,847 Posts
I've never seen this, but I would try to get some pictures and post them, someone will chime in I'm sure
 

·
Registered
Joined
·
3,382 Posts
A picture would be worth a thousand words here get us a pic
 

·
Registered
Joined
·
2,375 Posts
If you have the tank removed flush and clean the slim out with mineral spirits.If you have not mixed oils that did not play good with each other you have gotten moisture some how or another.
 

·
Registered
Joined
·
3,382 Posts
Looks like the pour point solvents dissipated in that oil I would completely flush that tank before adding new oil

Was that oil old that was in there previously

What oil is that brp oil isn't blue it has always been a brown shade perhaps Polaris oil

Sent from my iPad using Tapatalk
 

·
Ford hater
Joined
·
20,376 Posts
That or blue marble or amsoil?
 

·
Registered
Joined
·
3,467 Posts
Did you ever mix 2 different oils together in the reservoir? Looks like some kind of incompatibility problem to me.
 

·
Registered
Joined
·
2,375 Posts
The guy i got the sled from had it for a few years and only used BRP. I my self have only used BRP. I to was a little ??? over the color of the gel. Oh well its super clean now. Thanks everyone.
That blue tint to the tank didnt come from Doo oil..The mineral spirits did the trick ?
 
1 - 20 of 21 Posts
Top