Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter · #1 ·
Have an 04- MXZ 500SS. Summerized it like it said on DOOTalk. My first mistake was not to drain the tank prior to winter startup. When I started my sled up,it idled really bad. At low RPM's it sputtered. At high RPM's it ran great.
Took the sled to my dealer and they said it was bad gas.They said they drained the tank, cleaned the carbs, gave a treatment of octane boost and cleaned the power valves. Ran great from dealers shop.
Next startup, the same symptoms showed up. Poor idling, sputtering at low RPM's and an occasional stall. Once warmed up it ran better. However, the low RPM(5000)performance was still sputtering under light loads. If the throttle was pinned it went away.
So what do you guys think? I'm using high octance and using iso every fillup. The symptoms are less with each new tankful. Do you think it's bad fuel or water or what? What do you recommend.
Thanks Guys!
 

·
Just the Tip!!
Joined
·
2,504 Posts
Take of Your carbs and check out your pilot jets, they might have alittle gunk in them. spray carb cleaner through ure pilot holes in ure carbs to make sure there is a steady flow of fluid going through.

best
Blake
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #3 ·
BTANK said:
Take of Your carbs and check out your pilot jets, they might have alittle gunk in them. spray carb cleaner through ure pilot holes in ure carbs to make sure there is a steady flow of fluid going through.

best
Blake
[snapback]293379[/snapback]​
Thanks for the info. Since my dealer was supposed to have already drained/cleaned my carbs, should I return the sled?
 

·
Shoooow meeee the POWDER!!
Joined
·
3,849 Posts
I also say check the pilot jets. I had mine plug up on me last season on my '99 600 and it acted much like yours.
 

·
Just the Tip!!
Joined
·
2,504 Posts
I would do them yourself, there very simple. U can have it completed in an hour or so, a dealer would take a day or 2.

Blake
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #6 ·
BTANK said:
I would do them yourself, there very simple. U can have it completed in an hour or so, a dealer would take a day or 2.

Blake
[snapback]293404[/snapback]​
Thanks again..however, I'm not a mechanic. Is there a cleaner that you can use in your fuel?
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #8 ·
pcsledder said:
I would take it back to dealer, let them fix what they were to fix. No charge as come back!!!!!

[snapback]295943[/snapback]​
You're right pcsledder! Think I will. BTW how many miles you got on that brand new 05' MXZ 600 HO-SDI? Heard they eat up Yammi's
 
1 - 8 of 8 Posts
Top