Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
My '05 MXZ 550 fan, non e/s, has suddenly become very difficult to start as it seems to flood out easily. Once I do get it going there is a big puddle of fluid from the muffler. The longer it runs the less fluid there is until the next time I start it. The fluid smells like gas and oil. Causes / remedies? Thanks.
 

·
That's probably sarcasm.
2016 1200 Renegade X
Joined
·
20,966 Posts
Stuck float on the carb?

Sent from the Island of Misfit Toys.
 

·
Registered
Joined
·
27 Posts
Have you pulled the plugs to see if they are wet or need replacing? And a stuck float will certainly flood an engine.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #5 ·
The plugs are definitely wet. To the point where I'm replacing the new wet plugs with new dry plugs to get it to start. Then repeating the process a week later. Was leaning towards tearing the carbs apart but not sure if that is where it would end. Never seen that much coming from a muffler before. Other than this it has been a great sled. Especially for the kids
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #7 ·
So long as that's the end all-be all, I'm fine with that. Fingers crossed. Thanks
 

·
Premium Member
Joined
·
27,902 Posts
Fuel pump or carbs. Eliminate one possibility to find the other. Until it is found, run premix so there is always oil in the gas. A two stroke won't last too long with a too fuel rich mixture.
 
1 - 8 of 8 Posts
Top