Ski-Doo Snowmobiles Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I tried searching and have found nothing... so I have a 2009 mxz800r a d the engine is sitting nearly an inch lower on the clutch side. Not sure whats going on. The motor mounts all seem good but I have no idea whats going on. Nothing looks bent. I wrecked my sled and when I tore it down I noticed this but I thought it was because the chassis was so tweaked but I have replaced the tunnel/bulkhead and am in the process of putting the machine back together and the motor is sitting lower in this chassis too. All brackets appear fine a d mounts look good. If anyone can help it would be appreciated..
 

·
Registered
Joined
·
1,286 Posts
I'd say something gone wrong with the repair if the mounts all look good.

Need lots of pics to see what was done. Maybe we can collectively notice something off.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
1,286 Posts
It wasnt a repair I bought a complete chassis and put my parts on it. The chassis is straight. Unless it is the motor brackets maybe are bent I cant tell
Thought you said it was wrecked? Then you replaced tunnel, bulkhead etc?

Quote"I wrecked my sled and when I tore it down I noticed this but I thought it was because the chassis was so tweaked but I have replaced the tunnel/bulkhead and am in the process of putting the machine back together and the motor is sitting lower in this chassis too"

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
I wrecked the sled and thats when I noticed the motor sitting lower and I thought it was just because it was twisted. Sorry maybe just the way I worded it was confusing. I bought a chassis(tunnel,bulkhead) and put all my parts on there and the motor sits crooked jn this one too. But I just cant tell whats wrong.sorry for the confusion.
 

·
Registered
Joined
·
11 Posts
What year is the chassis. And are you sure you had the dampeners on when you set it in.
attachicon.gif
Screenshot_20200212-200208.jpg
Sent from my Pixel 3 XL using Tapatalk
Yes I used all the dampeners. One mount was slightly damaged(mag side) so I used one off a 600rs that I had. It appeared to be the exact same. New chassis is a 2008.
 

·
Registered
Joined
·
1,286 Posts
The part numbers are different for the 600RS mounts.

That has the be contributing to the issue. Since the numbers are different they must be different sizes.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #10 ·
Part numbers are different yes but they are the same thickness just 600rs are stiffer. To my knowledge that is the only difference.
 

·
Registered
Joined
·
1,286 Posts
Are you able to put the engine in with all the mounts, dampeners etc and take some pics. I'm wondering if something was caught up on the mag side and it wasn't spring completely flat.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #14 ·
Okay I think its this mount(above starter) without any bolts in it has this gap and the others sit flat on the rubber mounts. I put bolts in the other 3 and tightened them down and the engine seems to sit fairly straight now..
 

Attachments

·
Registered
Joined
·
1,286 Posts
Okay I think its this mount(above starter) without any bolts in it has this gap and the others sit flat on the rubber mounts. I put bolts in the other 3 and tightened them down and the engine seems to sit fairly straight now..
Yes that's def off.

Might be worth it to get all new mounts. It would suck to get it all together only to still be slightly off due to another bent mount.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #17 ·
Yes that's def off.
Might be worth it to get all new mounts. It would suck to get it all together only to still be slightly off due to another bent mount.
Sent from my Pixel 3 XL using Tapatalk
I guess thats what Im going to do I wouldnt be surprised if any other ones are tweaked slightly too... by the time its all said and done with everything Ive done I almost could have bought another machine lol
 

·
Registered
Joined
·
1,286 Posts
I guess thats what Im going to do I wouldnt be surprised if any other ones are tweaked slightly too... by the time its all said and done with everything Ive done I almost could have bought another machine lol
Yep been there, once you start can't stop. At least you found the issue.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #20 ·
So I picked up a new engine support(that I figured was bent) and it made an improvement but still not perfect. Will get the other 3 and Im guessing that should sort it all out..
 
1 - 20 of 20 Posts
Top