Ski-Doo Snowmobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
I have an 05 440 and I'm concerned about the compression if it's too high. I'm putting out 182 on the PTO and 183 on the MAG side. Compression tester I'm using is a brand new Mac digital tester. It has a #3 base and hc domes on it. If I can get some advice if it is why too high would be greatly appreciated.


Thanks,
Benjamin
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #3 ·
If I can get another opinon on this would be great. I think this is way too high and don't want to blow it up.

Thanks,
Benjamin
 

·
Registered
Joined
·
78 Posts
i run the lc on my 05 and its around 125ps1 and from factory with the hc i think was around 145 so ya. my cr 250 isn't even that high
 

·
Registered
Joined
·
4,812 Posts
That sounds pretty close to me. Whoever put the #3 base gasket in it must have desired compression that high otherwise they wouldn't have installed it.

Why are you worried it will blow? Can you not locate 108 octane fuel? I have the same set-up in my '05 and I race it with 105 octane in it. No known problems.
 

·
Registered
Joined
·
1,765 Posts
Ben is another one of us lucky guys up here in the arctic that has lots of snow and lots of time to ride but no resources for the race fuel these beasts crave.

my opinion for him was that 180-185 sounded kinda high for me...and when youre running avgas (spec'd out at 105...and not to mention, all we can get our hands on) then you hate to push too hard and end up with a toasted topend over something as stupid as octane.

Ben...did you take the gauge down to the shop yet to see what my sled and tony's sled check out at??? it would sure help to have a comparison on the same gauge...

if you did...post up the info man.
 

·
Shortbus member
Joined
·
1,026 Posts
CoolFlyer said:
Ben is another one of us lucky guys up here in the arctic that has lots of snow and lots of time to ride but no resources for the race fuel these beasts crave.

my opinion for him was that 180-185 sounded kinda high for me...and when youre running avgas (spec'd out at 105...and not to mention, all we can get our hands on) then you hate to push too hard and end up with a toasted topend over something as stupid as octane.

Ben...did you take the gauge down to the shop yet to see what my sled and tony's sled check out at??? it would sure help to have a comparison on the same gauge...

if you did...post up the info man.
[snapback]707531[/snapback]​
Do you guys get the av gas real cheap? or free
 

·
Registered
Joined
·
443 Posts
b_etuangat said:
I have an 05 440 and I'm concerned about the compression if it's too high. I'm putting out 182 on the PTO and 183 on the MAG side. Compression tester I'm using is a brand new Mac digital tester. It has a #3 base and hc domes on it. If I can get some advice if it is why too high would be greatly appreciated.


Thanks,
Benjamin
[snapback]706792[/snapback]​
Hey Ben - Jeff here,

Make sure when you do the compression test that it's a "cold pull". Run the cold motor for 5 to 7 seconds before you do the compression test (WOT). 183 PSI is a bit on the high side but, you should be "OK" with 110 octane. If all you have is Avgas just make sure you jump up a main jet size so you don't "suraujik".

The cheap solution would be to put the #7 BG back in. But, the ideal solition is to put in the 14:1 or 15.5:1 inserts in with the #3 BG.

"Tavva isumagijakka" - 2 cents.
 
1 - 9 of 9 Posts
Top