Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
513 Posts
Discussion Starter · #1 ·
The Sled - 2000 MXZ 700 with a 136" 1.25 track, 23/43 gearing, Vforce3 Reeds, 2001 Pipe.

I have never had my clutches apart so I have no idea if they are stock or not. I would like to know what I shold be running for max rpm at wot. Right now I am only getting 7500 at wot on the stock tach. Also what sholud my engagment rpm be? What tools do I need to remove, take apart and make clutch setting changes? Also what should I look for when I do get them apart?

Thanks
 

·
Registered
Joined
·
1,204 Posts
How long have you had the sled?
You should be hitting just over 8000 on the stock tach when WOT.
Chances are your clutches need to be cleaned inside. Well you have them apart I would swap out the springs with new ones.
You will need a clutch puller to get the primary off. Secondary just unbolts. You can make a clutch tool to compress the springs and get the clutches apart. Check the tech section as there is a great post on how to make these tools and how to take apart and clean. Great thread.

HTH
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #4 ·
I adjusted my clickers from position 3 to 4 and that brought my RPMs at WOT to just below 8000. I saw a few posted that had mentioned drawing a line with a Sharpe on the primary clutch to see how far the belt shifted out. I did this and the marker line is completely gone after a WOT run. What do I need to do if anything to fix this. Thanks
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top