Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
188 Posts
Did you lift the rear to see if it's coming from the tracks.there are quite a few grease fittings on the front sprocket shafts.including 3 under the middle plate on each side of the tracks.bearing?
 

·
Registered
Joined
·
106 Posts
theres 4 drive bearings fttgs, never seen 3 under inspection cover? i know the coupler has a fitting, but that doesn't do anything (the shafts are solid)

sounds like a stick rubbing the track only at higher spds
 

·
Registered
Joined
·
188 Posts
theres 4 drive bearings fttgs, never seen 3 under inspection cover? i know the coupler has a fitting, but that doesn't do anything (the shafts are solid)
sounds like a stick rubbing the track only at higher spds
. Ooooooookaaaaaay.let,s get a zert war going .better than a nerd ware loll .
 

·
Registered
Joined
·
56 Posts
Did u check for bolts loose on the hubs where the 2 shafts couple together... Mine came loose and bolts fell out. Eventually loose drive to one side.... Have to take lower inspection cover off
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #6 ·
Did u check for bolts loose on the hubs where the 2 shafts couple together... Mine came loose and bolts fell out. Eventually loose drive to one side.... Have to take lower inspection cover off
yes, i've changed that belt a couple yrs ago and check the coupler every season
 

·
Registered
Joined
·
82 Posts
the elite makes a ton of noise from under the seat, i find the snow kick up from the tracks and melts under the frame and then freezes, and every few bumps it knocks it off making a hard tick noise, if this possibly ur issue than its very normal

Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top