Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter · #1 ·
hello all. here's my problem: from a stop on a smooth lake if i put it to the bars, it goes right to 8200 rpm's and pulls like hell to about 25 mph then rpm's fall to 7400 and it just pulls along till it tops out at about 115 on the speedo. i have the stock 53-44 helix had the stock spring on setting b-5. i changed to setting b-3 and what a difference. darn near riped my arms off. it goes to 8200, then drops a little to about 7900 or so and pulls real hard. i didn't get a full speed run with this setup because conditions turned rainy and slushy. my question is: is it okay to run the spring this tight? i feel 1 setting tighter ( b2) and it would be perfect, but it was all i could do to wind it as tight as it is. i have a hook tool on the way so i can measure the tension, should have it tomorrow. i have a 1.25 track with 144 studs and i am not expecting huge top end speeds but i want it to pull like it's supposed to. would changing the clicker setting (i'm at 3 now) help or will it just do the same thing at a higher rpm? my primary is all stock, any suggestions?
 

·
Registered
Joined
·
263 Posts
Discussion Starter · #2 ·
ttt
 

·
Registered
Joined
·
263 Posts
Discussion Starter · #4 ·
cool, thanks. i got my spring hook tool today and i'll measure what i'm at. is there a limit to how tight you would want to go or is there another way to make it shift slower without winding the hell out of the spring? thanks and standby-
 
1 - 6 of 6 Posts
Top