Ski-Doo Snowmobiles Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter · #1 ·
Anyone had a problem with leakage on the chain case of the 05 rev 800? I cant tell where the leak is coming form but the dip stick has oil on it and oil is in the foot well. I thought it might be leaking past the sip stick o rings, but I know dont think it is. Top seal is dry. maybe leaking form the chain adjuster bolt?
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #4 ·
dilligafdog said:
is it chain case oil or injector oil. smell it there is a diffrence
[snapback]747253[/snapback]​
Its chain case oil. Before todays ride I cleaned it all up and wrapped the dip stick with a white rag. When I got home the rag had oil on it. The weird thing is I never noticed it leaking last year. Maybe its because we have been doing alot of very high speed cruising at WOF for 5 or mor emiles at a time.
 

·
Registered
Joined
·
2,582 Posts
bwalker said:
Anyone had a problem with leakage on the chain case of the 05 rev 800? I cant tell where the leak is coming form but the dip stick has oil on it and oil is in the foot well. I thought it might be leaking past the sip stick o rings, but I know dont think it is. Top seal is dry. maybe leaking form the chain adjuster bolt?
[snapback]747195[/snapback]​
My chain case does the same thing not much but just enough I cant figure out yet if its chaincase oil or resivior oil ski-doo needs to fix this prolblem along with better durabilty on the powertek motors my top half blew with 3200 miles on the motor and Im not the only one been hearing alot of the powertek motors blowing I have an 05 800x awessome sled though!
 

·
Registered
Joined
·
626 Posts
I think my chain case is leaking and i dont know why. Its a 06 600sdi X. I just bought it, it has 1200 mils on it. I have had it for 3 or 4 weeks and the first 3 weeks it didnt leak, and then all of a sudden it started leaking. Can someone tell me what it is?
 

·
Registered
Joined
·
151 Posts
It could be any or none of the following.

Bad gasket
loose cover
over filled case will blow excess out dip stick
bad seal on drive axle
oil reservoir cap leaking
defective case/cover

or somebody screwing with you and putting it there on purpose


There is also a front and back side to the dip stick, make sure it's installed the correct direction. Consult owners manual for correct position.

The oil could have dripped down from the oil reservoir onto the rag also.


Good luck
 

·
G MAN
Joined
·
5,381 Posts
dooman33 said:
I think my chain case is leaking and i dont know why. Its a 06 600sdi X. I just bought it, it has 1200 mils on it. I have had it for 3 or 4 weeks and the first 3 weeks it didnt leak, and then all of a sudden it started leaking. Can someone tell me what it is?
[snapback]893395[/snapback]​
Pull the chaincase cover off and inspect the metal contact edge of the case - needs to be clean w/ no gouges. Check the case gasket, dipstick o-rings (2), and chain tension bolt o-rings (2). If those are all okay then pull off the gears and chain and remove the rear of the case. Check the bottom drive axle seal for cracks and make sure it's seated properly. Check the upper jackshaft seal behind the bearing. And finally, there is an o-ring inside the jackshaft spacer that goes between the case and the brake rotor - make sure that it's in good shape and in it's groove inside the spacer. The o-ring side faces the rear of the chaincase.

Have FUN!

G MAN
 

·
Fuzzy but not Blue........
Joined
·
10,675 Posts
Are you running the chaincase stock or has it been ported???
If it has been ported did you do it yourself or did you send it out to have it done? It may have something to do with it. Curious to who did it if you sent it out. This would help.
-Grover
 

·
ITs WINTER!
Joined
·
7,497 Posts
My guess is that its coming out the vent, which is the dipstick. If you take a good look at it you will see the small holes in it!
 

·
Registered
Joined
·
626 Posts
Well i went and checked it today, and the leak has stopped. Do you think it could be from me starting it a lot? When i get a new sled i just have the itch to start it a lot. Also could it be from the way its been sitting. I had it up on the dolly's since i got it. But the other day i took them off. Also it sat in my driveway which is on a slant for about an hour or so the other day because i was washing my car. So do you guys think it could be any of those things?
 

·
G MAN
Joined
·
5,381 Posts
dooman33 said:
Well i went and checked it today, and the leak has stopped. Do you think it could be from me starting it a lot? When i get a new sled i just have the itch to start it a lot. Also could it be from the way its been sitting. I had it up on the dolly's since i got it. But the other day i took them off. Also it sat in my driveway which is on a slant for about an hour or so the other day because i was washing my car. So do you guys think it could be any of those things?
[snapback]894002[/snapback]​
No

Mine has never leaked and my sled's been upside down on several occasions. Maybe yours is just overfilled like Irondog said? It's not that difficult to go thru my checklist - I can pull the entire chaincase in less than five minutes with an impact wrench.

Have FUN!

G MAN
 

·
Registered
Joined
·
151 Posts
Constantly starting it and letting it idle during the summer isn't a good idea, you're not loading the motor and if it doesn't reach operating temp you'll get condensation in the motor.

Are you sure the oil is from your chain case? It might be from the oil reservoir. Where exactly is it leaking from? That might help diagnose the problem.

Start by checking the chain case oil level, then drain the chain case - remove the cover and inspect the gasket.

You shouldn't have a bad seal with only 1200 miles.
 

·
Registered
Joined
·
626 Posts
Alright thanks guys ill look into that. Sorry i didnt mean to seem like i started it like everyday maybe like 3 times over the course of 3 weeks is that still to much?
 

·
Registered
Joined
·
151 Posts
dooman33 said:
Alright thanks guys ill look into that. Sorry i didnt mean to seem like i started it like everyday maybe like 3 times over the course of 3 weeks is that still to much?
[snapback]894068[/snapback]​
No, just make sure you let it warm up to operating temp before shutting it down.
 
1 - 18 of 18 Posts
Top