Ski-Doo Snowmobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1,361 Posts
OntheGasandKickinAss said:
I rolled my sled and have fixed everything but the carbs it starts fine and idles fine but when i give it gas it boggs out unless i tap the throttle then it gets up and goes any ideas??


[snapback]253799[/snapback]​
it could be the float or the needle stickin or the crank seals
good luck
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
citationuser said:
OntheGasandKickinAss said:
I rolled my sled and have fixed everything but the carbs it starts fine and idles fine but when i give it gas it boggs out unless i tap the throttle then it gets up and goes any ideas??


[snapback]253799[/snapback]​
it could be the float or the needle stickin or the crank seals
good luck
[snapback]253811[/snapback]​
thanx wasnt a bad roll though dont think it would be a crank seal
 

·
Registered
Joined
·
308 Posts
OntheGasandKickinAss said:
citationuser said:
OntheGasandKickinAss said:
I rolled my sled and have fixed everything but the carbs it starts fine and idles fine but when i give it gas it boggs out unless i tap the throttle then it gets up and goes any ideas??


[snapback]253799[/snapback]​
it could be the float or the needle stickin or the crank seals
good luck
[snapback]253811[/snapback]​
thanx wasnt a bad roll though dont think it would be a crank seal
[snapback]253813[/snapback]​
I bet that when it rolled, all the junk at the bottom of the float bowl got stuck in the carb jets. Pull off the carbs and blow out all of the jets and circuits.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top