Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter · #1 ·
Well, 8500kms of excellent performance from my '05, until today. I noticed that my attachment bracket at the top of the pyramidal frame is broken (you can see it from where the steering post comes out of the center console), I recal that Early Rider may have had this same problem. Anybody else have this happen to them???. Check yours out.
 

·
Premium Member
Joined
·
1,955 Posts
I recently noticed the two bolts behind the secondary at the bottom of my pyramid were so loose they were about to fall out. Had to take off the secondary to retighten the lower one.
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #3 ·
BlueMax said:
The pryamid and steering attachment bolts were items discussed at the end of last year as items that required checking several times a season.
[snapback]732785[/snapback]​
This had nothing to do with loose bolts Blue, all bolts are still tight and I checked them last year after reading on dootalk that they may come loose, everything was tight before I took it in for updates. The bracket just broke. I guess this isn't a common problem, anyways no riding this weekend and conditions are great,,,Bummer.
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #4 ·
BlueMax said:
Zyou said:
BlueMax said:
The pryamid and steering attachment bolts were items discussed at the end of last year as items that required checking several times a season.
[snapback]732785[/snapback]​
This had nothing to do with loose bolts Blue, all bolts are still tight and I checked them last year after reading on dootalk that they may come loose, everything was tight before I took it in for updates. The bracket just broke. I guess this isn't a common problem, anyways no riding this weekend and conditions are great,,,Bummer.

[snapback]733661[/snapback]​
Is this the bolt on piece that the steering column goes through? Probably not a part a dealer would have on the shelf. That is a bummer.
[snapback]733673[/snapback]​
Yup, that's the part. in the BRP parts catalouge it's 09-frame and components Ref # 11. And your right my dealer had to order it in. Just can't beleive that I'm the only one that has had this happen, I'm not affraid to ride hard but I don't make a habbit of it. Too many wheelies I guess!.
 

·
boost junkie
Joined
·
10,603 Posts
If you have one on order have the darn thing welded!!!

A local welder can do it quick
 

·
Registered
Joined
·
1,344 Posts
BlueMax said:
Zyou said:
BlueMax said:
The pryamid and steering attachment bolts were items discussed at the end of last year as items that required checking several times a season.
[snapback]732785[/snapback]​
This had nothing to do with loose bolts Blue, all bolts are still tight and I checked them last year after reading on dootalk that they may come loose, everything was tight before I took it in for updates. The bracket just broke. I guess this isn't a common problem, anyways no riding this weekend and conditions are great,,,Bummer.

[snapback]733661[/snapback]​
Is this the bolt on piece that the steering column goes through? Probably not a part a dealer would have on the shelf. That is a bummer.
[snapback]733673[/snapback]​
Mine didn't break but rather broke the bolt that goes through it. I broke that part myself trying to drill out the broken bolt. O then proceeded to install a 1/4 bolt with nyloc nut. Yesterday it would appear it snapped as well as its gone and I can't see a nyloc nut backing off.
BlueMax this is the very top of the 3 bolts which goes through the steering as well. I do ride this sled and it must be the pounding but starting to wonder if there may be another weak spot with something missing causing this to happen.
 
1 - 6 of 6 Posts
Top