Ski-Doo Snowmobiles Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi!

I have a 1200 turbo , 146"inch about 320HP.

Running a STM rage 4 primary , 74gr weight pins , PL 160/320 primary spring and secondary : 47/40 helix (will change to 47/50) and white ski-doo spring.

The secondary is shimsed out 2mm so i now have 37mm distanse on the primary clutch.

3km ride and "threads" are hanging out from the belt on the outside.

I need some tip so i dont blow my belt all the time..... any ideas ?

Sorry for the bad english :rolleyes_old:
 

·
Registered
Joined
·
2,726 Posts
Did this happen in the first ride?

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Yes after 1 run.

57mm challenger Original gearing in the chaincase :)

I hadd another spring from 2008 summit 800 with 47/40 helix and no preload.

Now i have 90Degres preload on the white doo spring.
 

·
Registered
Joined
·
575 Posts
47/40 helix is fine

Ski doo white spring fine with 26 pds preload

final gear ratio should be around 1.5 (28/43)

Can not help with primary as we run TAPPs

This is on 120
 

·
Registered
Joined
·
2,726 Posts
Wondering if you had a bad belt??

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
981 Posts
Have you blown belts yet with this set up?
What type of belt?
How is the parallelism of motor to secondary?
Meaning is the motor twisted compared to secondary?

What style weight? Who's weight is it? And weight placement on the weight? Heel, mid or tip?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
brand new 391 belt.

Stock engine mounts yes but will try to fasten it now in the weekend with shims :)

Clutch aint that hot , but i think the primary and the secondary is in line when i hit the throttle.
 

·
Registered
Joined
·
2,726 Posts
Get a new belt. Try again.

Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
Top