Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
451 Posts
Discussion Starter · #1 ·
Toke my sled for a ride last night and it made this wierd noise when i went up a hill, only for a quick second. I stopped on top and let it idle, it sound normal idleing at 1800rpm. when i toke off it was ok, no bogging or anything. I was going about 80 mph on the trail but when i stopped again it didn't even idle, it just died. I did a compression test and pto was 125 psi and mag was uder 10 psi. I think i just blew my ring on the mag side.

Now i'm worried, i don't know what else to check eg. crankcase,bearings ect ?

If my cylinders, pistons, and head are fine would it be safe to just replace my ring and ride for the rest of this year or should i do a complete rebuild ???

I think the engine has about 9000 miles or more

need help fast, there callin for another snow fall this weekend

Thanks in advance

Andrew
 

·
Mainway Solutions Inc.
2020 Renegade XRS
Joined
·
2,883 Posts
No Quick Fix
you need a rebuild
That low cylinder presure is telling you something
you problem is lean
find the problem first and then rebuild
your piston is "edit for bad language"ed for sure
maybe your barrel is ok just a hone or bore
either way you have a fuel/seal problem you have to contend with first
Good luck
 

·
Registered
Joined
·
188 Posts
this actually happened to me - check the oil reservoir, I had a sled that seized, turns out there was a seal from a bottle of oil in the reservor - it got sucked into the drain hole and starved the engine for oil...you never know
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #4 ·
well i finally got my engine takin apart and it isn't as bad as i thought. I still have both rings on the piston's. here are some pics, notice the mag piston has a chunk missing under the ring
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #5 ·
ok well the pic didn't add, can someone tell me how to add a picture properly ?

Andrew
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #6 ·
TTT
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #7 ·
rampage said:
When that happens, it's better not to run a compression test because you can cause more damage. Better just to tear it down right away. Once the jugs are off, see how easy it spin the crank. You can also pull the RV cover to see if any pieces got stuck between the plate and the case. Hopefully it's only a top end, but it's better to inspect everything before spending any $$

You have to make pics a small size (I think 70K or less maybe?) before you can post them.
[snapback]727929[/snapback]​
I toke then engine apart except for the bottom end, the only thing that was gone was my MAG piston, i still had the ring on it tho. my cylinders look fine,doesn't appear to be any scratchs ect. the only real visible damage is that the top of the MAG piston is all chipped and under the ring theres a deep chip/scratch. The PTO piston is fine, nothing damaged.

should i still rebuild the bottom end ?

As for the pictures i'll have to check the size of them

Thanks
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #8 ·
rampage said:
ski--doo all the way said:
should i still rebuild the bottom end ?

[snapback]727983[/snapback]​
at least try to inspect it. It's pretty easy to pull the rotary valve cover (4 bolts) and many times if anything got in the bottom you will see evidence of it on the RV surface. You can also try to look down around the crank journals and see if you can see any schrapnel. If the rv surface is cherry, the crank spins fine, and you can't see any loose pieces down below, slap a piston in it and go.
[snapback]728172[/snapback]​
Well i toke a good long look at my bottom end tonight, i noticed that my connecting rod bearings are finished (they have too much play in them). I think i'm just going to do a complete rebuild of the whole engine. One thing that scares me is taking apart the rotary valve, i don't know how to install it properly.

Doesn't one of the pistons have to be TDC??
and how does the rotary valve face (half moon down or up ect ??

Andrew
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #9 ·
blown_piston_2.jpg blown_piston_1.jpg Finally got my pics to work. her are some pics of the MAG piston
 

Attachments

·
Registered
Joined
·
451 Posts
Discussion Starter · #10 ·
good_piston.jpg blown_piston_3.jpg another 2 pics, one is the PTO piston (nothing wrong with it)
 

Attachments

1 - 10 of 10 Posts
Top