Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter · #1 ·
had a 05 machz I bought late last year and it vibrated a lot more than my old 800 twin!!!!!
this year with about 200 miles of riding the mag rod siezed!!!!!!!!
lucky for me I bought extended warranty and a used (200kilometer) motor (wanted to have spare parts)
I installed used motor cause crank was on back order(that was 2 weeks ago and dealer said motor will be ready this week) anyway the used motor DOES NOT vibrate anything like my original motor, its as smooth as my 600 sdi!!!!!!!!!
thinking maybe thats why the knock sencors are reducing the timing on these high vibrateing sleds!!!!!!
just my thoughts
ckm
 

·
Registered
Joined
·
0 Posts
I only had a chance to try two Machs and to my surprise they were very smooth. They were both smoother and quieter than my 800 Rev but not as smooth or as quiet as my wifes 05 600 sdi. For a big twin they are much smoother than the Cat 900 and everything is smoother than the Fusion 900
I think if your Mach vibrates badly then you have problems.
 

·
Registered
Joined
·
2,293 Posts
Mach1Z said:
What do you mean by bad? At idle my handle bars vibrate pretty good, but as soon as you crack the throttle it's gone. Is this normal.
[snapback]704901[/snapback]​
At idle mine doesn't vibrate much at all,but I do remember in the first 10 hours or so it was very rough.
I have seen 2 different machs with the right rear mount having a rubber seperation problem though.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top