Ski-Doo Snowmobiles Forum banner
1 - 20 of 91 Posts

· Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
brought home new Neo, brought back to dealer 2 days later - with excessive smoke & lower knocking --- can't determine if it's motor or clutch; gets worse as it warms up. sounds like ball bearings in the cylinder; rpm's rise & fall between 1500-1900, not steady. manual is crap; info is crap... states clutch engagement at 3200, actually it's at 2200.

has anyone else had any issues? very disappointed BRP
 

· Registered
Joined
·
1,289 Posts
brought home new Neo, brought back to dealer 2 days later - with excessive smoke & lower knocking --- can't determine if it's motor or clutch; gets worse as it warms up. sounds like ball bearings in the cylinder; rpm's rise & fall between 1500-1900, not steady. manual is crap; info is crap... states clutch engagement at 3200, actually it's at 2200.

has anyone else had any issues? very disappointed BRP
No issues with Neos in our shop. Not many of them in the field, but the 600 EFI has proven to be a very reliable engine and I was assume a detuned 600 EFI in the Neo would be even more reliable. Good luck!
 

· Registered
Joined
·
65 Posts
brought home new Neo, brought back to dealer 2 days later - with excessive smoke & lower knocking --- can't determine if it's motor or clutch; gets worse as it warms up. sounds like ball bearings in the cylinder; rpm's rise & fall between 1500-1900, not steady. manual is crap; info is crap... states clutch engagement at 3200, actually it's at 2200.

has anyone else had any issues? very disappointed BRP
with that low of engagment id deff be looking at my clutch see if something is off.
 

· Registered
Joined
·
3,166 Posts
I don't even know why he's troubleshooting it on a forum. It's a brand new sled w/ zero miles on it. If it sounds as bad as the OP says & it was me, it would be headed straight back to the dealer.

manual is crap
That's not new. The manual for my 2018 XS chassis Blizzard shows the induction ducting for an XP sled.
 

· Registered
Joined
·
11 Posts
Discussion Starter · #15 ·
am back. this is what i got: dealer had the sled for 2 weeks ... dealer told me he has no manual on it; (have no idea why he couldn't go online to find it.), & he's had no training for his mechanics yet. thought the motor was blown so gave me another Neo + they had just put together. haven't been back online to give update until today --- NOW I have snow to run it on. This new machine --- wait for it..... hold onto your chair..... makes the SAME noise.... it runs fine; just randomly makes a knocking noise between idle & 2000 rpm. what's the odds of 2 machines, vin numbers only 1 digit apart; both with same issue?? my best guess its either the break-in process AND the lack of an expansion chamber (is just a bent 2" tube) and whatever they did to the ECU to detune it to make 55 ponies. other then the knocking noise it runs like a beast and handles great ...I got 3 years of warranty if it hand grenades it on BRP ....
 

· Registered
Joined
·
103 Posts
am back. this is what i got: dealer had the sled for 2 weeks ... dealer told me he has no manual on it; (have no idea why he couldn't go online to find it.), & he's had no training for his mechanics yet. thought the motor was blown so gave me another Neo + they had just put together. haven't been back online to give update until today --- NOW I have snow to run it on. This new machine --- wait for it..... hold onto your chair..... makes the SAME noise.... it runs fine; just randomly makes a knocking noise between idle & 2000 rpm. what's the odds of 2 machines, vin numbers only 1 digit apart; both with same issue?? my best guess its either the break-in process AND the lack of an expansion chamber (is just a bent 2" tube) and whatever they did to the ECU to detune it to make 55 ponies. other then the knocking noise it runs like a beast and handles great ...I got 3 years of warranty if it hand grenades it on BRP ....
It’s likely normal for that sled
 
1 - 20 of 91 Posts
Top