Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So, after having read all the current threads still cant get her started. Had it running friday ,started first pull. Ran fine,loaded it up n drove down for christmas. Got here and started it saturday and once again started first pull, let it warm up and hit rer toback it off and it just died, started 1st pull again let it idle a litte again hit rer and again it died.... hasnt started since.

Got it unloaded with help and in the garage, battery was weak so i replaced it, checked all fuses n relays there good. Fuel pressure gauge reads 55psi after pump primes it. Got 130 psi in each cylinder cold open throttle on 3 pulls.

Checked and ive got fuel getting to cylinders almost too much, gotspark on both caps with 2 new plugs.

Whats got me is ill try pulling it ove to no avail, pull the dess key and next time i come out and plug it in and pull it over it beeps twice after each pull like its started, but its not.....

Any advice ?
 

·
Registered
Joined
·
539 Posts
not sure.. I would clear out the gas and new plugs and see if will fire. If not prime a half once of gas in each cylinder and try again. Also clean the dss connection and check dss connection. seems like you have gas and spark... But foulded plugs can be a PITA when troubleshooting. Good luck.
 

·
Registered
Joined
·
539 Posts
oh. maybe swap the relays around and see if anything changes. If priming with new plugs wont fire than it gets ugly, maybe weak coils but thats unlikely as Ive never touched mine. I foulded lots of plugs before I got a decent ecu program,,, plugs that sparked only when uninstalled caused me lots of greif. mid alt and a good TPS setup helped alot.
 

·
Registered
Joined
·
2,803 Posts
Try a fresh set of plugs BR8ECS, 130 is kind of low but shouldn't keep it from running. Is this the 1st time you've ridden it this season ?
 

·
Always wrenching on something!
Joined
·
2,905 Posts
check your raves, or pull the cables and try that, i juts had rave troubles, sled would idle like crap or barely idle, would NOT go into reverse.... i pulled my rave cables off and turned the raves at idle and discovered an issue, fixed it and it idles like a champ, also goes into reverse as it should
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Well i got it started finally, i had tried new plugs, and relays. Guess it had just flooded good. Pulled all fuses n relays, and between 2 people we pulled it over quite a bit then let it sit over a beer or two reinstalled fuses n relays and plugs and she fired up, took it out put 26km on it and used rer all works 100%.
 

·
Registered
Joined
·
111 Posts
my rt1000 is oiled up high. she is happy with 4500 miles on motor.
but ... she eats plugs!
sometimes they last a day.
normally i get a month on average.
keep in mind she runs everyday I can start her, which is almost everyday.
I currently have 6 spare plugs,
its the first thing I do if she gets cranky.
she likes new plugs and clean gas !!!
 

·
Registered
Joined
·
266 Posts
my rt1000 is oiled up high. she is happy with 4500 miles on motor.
but ... she eats plugs!
sometimes they last a day.
normally i get a month on average.
keep in mind she runs everyday I can start her, which is almost everyday.
I currently have 6 spare plugs,
its the first thing I do if she gets cranky.
she likes new plugs and clean gas !!!
What oil are you using???
 

·
Registered
Joined
·
229 Posts
Have you updated the mapping on it? Also should look into a boondocker for it to correct the fueling issues that still exist after updating the mapping.
 

·
Registered
Joined
·
111 Posts
does it idle low?
cleaning raves and reeds is a great way to fix prob's relating to starting, idling and switching to reverse.
we have 2 of these beasts in this house and I'm constantly looking over them.

the oil is brp's recomendation ... I cant remember right now ... xrp ???
mine uses far more oil than my buddy's. almost twice.
I bought it off the dealer in town X-demo, it was his personal sled, he set it up, I ride it, and luv it !!!
 
1 - 10 of 10 Posts
Top