Ski-Doo Snowmobiles Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
56 Posts
Ran the lake the for a few minutes tonight... Was following a couple buddies, sled started a bog mid to top end rpms, something I have seen before but ran 3500km strong. Threw a code, rode for another minute and completely shut down. Tons of white smoke rolling off, thought I was gonna have a burn down on the lake. Thanks to my buddies for the tow back to camp. We pulled the clutch side plug. COOLANT "edit for bad language" out the plug hole "GREAT". The plug is caked in oil.
ffb5c43b45a1ce63f442911c5c1e3613.jpg
Possible head gasket? Hydro lock? Obviously a tear down is necessary. Any past experiences? Yes I know I should have stopped when I threw a code so keep that to yourselves if you don't mind. What's done is done.

Thanks boys! Happy riding looks I'm out when its starting to get good, 600km so far. Could be worse.

Skidooangelo
55c9689957b09584adaf993a42e5e161.jpg
 

·
Premium Member
Joined
·
27,904 Posts
That engine needs a leak test done prior to removing the head. Once the head is off it will be 800 times more difficult to determine the cause of the leak.
 

·
Premium Member
Joined
·
27,904 Posts
By the way, don't worry too much about having ignored code. Everyone is at the mercy of the day's ride, no exception. If the code has been stored than it can be read, probably better sooner than later.
 

·
Registered
Joined
·
83 Posts
My 14 800 etec did the same thing last weekend. Started burning coolant then it hydro locked. 3500 miles on the sled. Luckily it's under warranty and ski-doo is sending a new short block as the dealer was unable to find a definite source of the coolant.

Two 800 etec engines in the past 3 years. First one with 2300 miles (blew up), now this one with 3500 miles (coolant)...
 

·
Premium Member
Joined
·
27,904 Posts
This kind of failure should never happen.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #12 ·
Barski you've had luck with these things... Couldn't find the definite source scares me.

I'll be probably taking it to the dealer Monday, was thinking about a couple other mechanics. Not 100% which route I wanna take.
 

·
Premium Member
Joined
·
27,904 Posts
Barski you've had luck with these things... Couldn't find the definite source scares me.

I'll be probably taking it to the dealer Monday, was thinking about a couple other mechanics. Not 100% which route I wanna take.
I would consider the person with the most time/incentive/initiative to find the source of the leak.
 

·
Registered
Joined
·
3,600 Posts
That engine needs a leak test done prior to removing the head. Once the head is off it will be 800 times more difficult to determine the cause of the leak.
Dido just a trip to the hardware store and you can make one. I found a missing weld on my dyno port Y pipe after my rev went down. It works you can do it and it's easy.

I've pulled my 11 etec motor out to do the water pump. Its not that hard just take time more then a rev. Have the dealer dianose the issue read the code then fix it yourself.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #17 ·
Dealer said its toast... He quoted me almost 4100 with taxes, seems high... Needs a sb and a thermostat... What are my options here?!
 

·
Premium Member
Joined
·
27,904 Posts
I think it is reasonable to assume an engine leak test was not done.
 
1 - 20 of 51 Posts
Top