Ski-Doo Snowmobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3,534 Posts
Discussion Starter · #1 ·
I know this is not an Arctic Cat forum, but I know I'll get some honest answers in here....

A buddy of mine has a 2015 Bearcat, the Barney chassis version, and we're having trouble getting it to back up.

It has an articulating skid, but as it came from the factory it was set so stiff that it was like a solid rail. We backed off the tension on the springs as far as we could, and still, you cannot lift the flip up portion of the skid by hand, though if you put a block under it and let the whole wait of the sled down on the block, it will flip up.

But what good is that? In soft snow there's not enough pressure on the flip up to allow it to articulate, and the sled just digs in like it had solid rails. It's useless.

Just wondering if anyone here has experience with modifying them so that it will work as intended. Removing the spring and cutting it, replacing the springs with softer springs, or running it with a spring on only one side are all things that have occurred to me.
 

·
Registered
Joined
·
180 Posts
I've recently fixed a bad vibration problem in a Turbo 660 Bearcat 2007 by installing an new jackshaft but that is about the limit of my Bearcat experience.
 

·
Registered
Joined
·
522 Posts
Before I sold my Bearcat, I removed the springs and it did help the reverse performance. It's talked about in this thread http://www.arcticchat.com/forum/bearcat-utility/329627-how-make-bearcat-xt-better-snow.html
Lol that was me that started messing with the rear flip. The best mod I did was sell it hahaha. But taking the springs out altogether worked the best. You'll need to use a heavy washer on the other side so it doesn't flip up too far if you know what I mean. I also put a rubber washer in there to keep it tipped up just a little. Should be able to see from my pics on that link. If you can't see them let me know I think I still have them on my computer. Wish I had the bearcat seat on my SWT though lol.

Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top