Ski-Doo Snowmobiles Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
32 Posts
Just wanted to post a pic of my old MAG piston, it's two years now since they were replaced with Wiseco. What could be the cause of the melting ? I replaced crank seals and checked everything. Have had no problems since.
By the way, the hole is drilled



 

·
Descending doooowwwwnnnnn
Joined
·
3,398 Posts
im no mach z expert,but my cousin who works on them told me the 98's with the pipe's that come up over the head are garbage,get a set of 99,or 00 pipes instead,he's worked on many 98 that melted down,and after the pipes were changed everything was ok..
 

·
Registered
Joined
·
24 Posts
DITCHBANGERPRO said:
im no mach z expert,but my cousin who works on them told me the 98's with the pipe's that come up over the head are garbage,get a set of 99,or 00 pipes instead,he's worked on many 98 that melted down,and after the pipes were changed everything was ok..
[snapback]752818[/snapback]​
Poor fuel or uncleaned carbs were most likely the cause.
 

·
Registered
Joined
·
79 Posts
once&forall said:
DITCHBANGERPRO said:
im no mach z expert,but my cousin who works on them told me the 98's with the pipe's that come up over the head are garbage,get a set of 99,or 00 pipes instead,he's worked on many 98 that melted down,and after the pipes were changed everything was ok..
[snapback]752818[/snapback]​
Poor fuel or uncleaned carbs were most likely the cause.

[snapback]753589[/snapback]​
Hello,

i have the same problem on MAG side after leaning both carburators(3).Probably that the MAG side stay hotter thand the others cylinder because closer to muffler.The 809 is very sensitive to jet leaning and float level modification and timing modification.STAY with the FACTORY SPECIFICATION .I have a 98Z with more than 54,000 km on it and the secret is FACTORY CALIBRATION and first grade injection oil(Polaris mineral blue.

Take care!

Z36qc
 

·
Registered
Joined
·
32 Posts
smallengineguy said:
What plugs were you running? It appears that the top of the piston started to melt away from the plug being too hot, then the metal F'd up the skirt as it was leaving the cylinder.
[snapback]754281[/snapback]​
This damage happened by the former owner. Plugs were BR9EYA as I bought the sled. I knew about the damage but I had to find a good cylinder also, and so on...
The other two pistons were fine, but I got a set of Wisecos instead.
 

·
Registered
Joined
·
3 Posts
smallengineguy said:
Usually when the crown of the piston is melted away, it's too hot of a spark plug, might want to see if it's slightly lean on that cylinder.
[snapback]755403[/snapback]​
My opinion 98 mach Zs are junk get rid of it.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #10 ·
Formula3700 said:
smallengineguy said:
Usually when the crown of the piston is melted away, it's too hot of a spark plug, might want to see if it's slightly lean on that cylinder.
[snapback]755403[/snapback]​
My opinion 98 mach Zs are junk get rid of it.

[snapback]756668[/snapback]​
No no you are wrong, this is the best sled ever made
 

·
Registered
Joined
·
24 Posts
Formula3700 said:
smallengineguy said:
Usually when the crown of the piston is melted away, it's too hot of a spark plug, might want to see if it's slightly lean on that cylinder.
[snapback]755403[/snapback]​
My opinion 98 mach Zs are junk get rid of it.

[snapback]756668[/snapback]​
I have two 98 mach z's and if you saw them run I don't think you would call them junk. They were the best year to mod in that style.
 

·
Registered
Joined
·
24 Posts
smallengineguy said:
Usually when the crown of the piston is melted away, it's too hot of a spark plug, might want to see if it's slightly lean on that cylinder.
[snapback]755403[/snapback]​
I don't think it was because of to hot of plug. When you have detonation all heck breaks loose in the combustion chamber and causes the piston to look like that. I have seen it quite often enough. Old gas loses its flash point and at wot the motor is going to be its hottest therefore it doesn't take much to set of the fuel before it is compressed.
 

·
Registered
Joined
·
209 Posts
I blew my center piston and it looked just like that (minus the drilled hole) I think it was because the guy i bought it from didnt clean the carbs this year. (even tho he said he did). Just got her thru break-in and she's running great. Stock calls for br10es plugs, but i pulled br9es out of it and from what i've researched they like to run on Br9eya's. So I'll be switching to br9eya's soon to regain my topend. Right now it only pulls 110 on the speedo. It had more topend acceleration before the rebuild.
 

·
Registered
Joined
·
6,219 Posts
By the looks of that engine somebody tows it on an open trailer with no cover or it sits in the backyard under the walnut tree? Could be part of the problem.
 
1 - 17 of 17 Posts
Top