Ski-Doo Snowmobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Hello all, I've fixed many of my issues by searching the through the wealth of information in your posts. Thank you.

This issue is weird and has left me stranded in the cold.

So It's happened twice. Running it for days out camping, then another chilly morning I prime like normal, and get a Very weak pop and then flooding symptoms. Open plugs, carb, and pull or let it sit ALL day and still Zero fire whatsoever. Then after the temp warmed up 30 deg or more it will fire up.

So the fist time I had put ISO heat in the tank and later realized I had stored the sled with a half tank... in Alaska....lots of water.

naturally I blamed the water. dumped tank,cleaned, flushed lines, pump, and cleaned carbs too.

2nd time same thing, fires great every cold morning. Then the morning we need to leave for home, one Weak pop

and one dead machine. Tried tenting it to warm it up with no success. 2 days later, 30 deg warmer if fired up just sitting outside.

I had to rule out flooding, always turn fuel flow off when sitting, It didn't clear out after sitting "open" all day.

Spark was present but definitely weak.

Coil, CDI (amplifier box)??? anyone have any experience with these symptoms?

Thanks again
 

·
Registered
Joined
·
3,378 Posts
That's a strange one... I've seen the opposite kind of spark issue, where the engine will start up when cold and then lose spark once it warms up to operating temp.

Have you tried new spark plugs? Test spark plug caps for resistance in spec range?

From there I'd do primary & secondary resistance tests on the ignition coil when it is exhibiting the weak spark condition. If the coil tests within the specified resistance range, move on to testing the stator.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yup, New plugs put in, both occasions. Im gonna dive into the resistance tests you suggested. Electronic trouble shooting is definitely not my strong suit. time to get into it though. thanks Moto
 

·
Registered
Joined
·
5,062 Posts
Colder it is, the more fuel it needs. 583 is cantankerous.

-10F and colder cold start procedure: 3 squishy primes, pull until it pops. 2 more primes, 1/8 throttle, pull until it starts (typically 2-3 pulls).
 
1 - 4 of 4 Posts
Top