Ski-Doo Snowmobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter · #1 ·
hey all,
on my 94 stx rear suspention, the shaft and wheel assy. that holds the shocks to the rear of the tunnle frame dont turn.i had the suspention out in the summer rebuilding it and now when i run it on the stand their is a flat spot starting on theis plastic wheels.theis are the wheels that are on the alum shaft that have no baerings.what gives did i forget something when reasembling it or are the brass fittings that are on this shaft that the shocks mount to supose to turn freely ? they dont right now.
after you put the shaft in a tourqe it to spec it dosent wont to turn.

sorry for such a long post but its the best i can discribe it.any help would be appreceated.

if you go to ronnies.com and look up a 94 stx and look at the rear suspention the numbers are 52 and 53 on the dieogram for this assy.
 

·
Registered
Joined
·
214 Posts
Those plastic wheels are not supposed to turn. They are not intended to make firm contact with the track at all times. They are there to keep the track from flexing down too far. When you put it back together, turn the shaft so the flat side is away from the track. They act the same as the steel loops on the front of the skid that are on the ends of the shaft that the front shock bolts to.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #3 ·
hey thanks for the info i thought i did something wrong on reassy,it just seems that they sould turn.mybee i had the track ajusted to tight ?
thanks
 
1 - 3 of 3 Posts
Top