Ski-Doo Snowmobiles Forum banner
1 - 20 of 31 Posts

·
Registered
Joined
·
811 Posts
i have a 2009 mxz x 800r with 2100 miles ran perfect last season but this year whenever i start it up it idles fine and i let it warm up for 5-10 mins and then when i rev it it will rev up fine but when i let off the gas the idle drops the electronics cut out and eventually the sled will cut out.... it will restart and if i keep my thumb on the gas it will run and rev up but when i let off the gas it'll idle down to 950 rpm and cut out... any ideas are appreciated... ive cleaned the carbs and it ran perfect that day but now its back to the same old problem now.... heres a video of the problem. it had already died out once so i have to keep my thumb on the gas to keep it running and i didnt hit the kill switch at the end it died out on its own... i dont know why the gas light is on it has gas... just more problems i guess, it never worked great to begin with though.

 

·
Registered
Joined
·
462 Posts
I would be pulling the carbs off again, remove the pilot jets and the fuel screws, clean out the pilot circut with carb cleaner and compressed air, clean pilot jet with a small wire or, a torch tip cleaning wire being carefull not to force it in. Check main jet the same way. Check needle valve and seat for dirt or obstructions. While you have the carbs off i would be checking the reeds for cracking and chipping and the rubber boots for cracks, sounds like you could also be pulling in air somewhere. When installing carbs make sure there are no pinched lines and that all connecters are plugged in. Make sure the choke cable setting is correct, make sure the plungers are returning all the way back after releasing the choke lever. Almost for got, the fuel screw setting should be one and a half turns out. New gas and plugs and hopefully your ready to go. Good luck.
 

·
Registered
Joined
·
811 Posts
Discussion Starter · #4 ·
in addition to the idle problem though after it dies out a couple times when i hit the gas its like half throttle because like quarter throttle and the sled wont rev past 6000 or so and then it just get worse and worse.... pretty soon i can put the throttle to the bar and itll only rev to 4000ish and it will of course die out once i let off the throttle... its just weird because after cleaning the carbs it ran like a champ on the stand several times..... but now its back to the same old problem...
 

·
Registered
Joined
·
390 Posts
Might have small amount of crap in tank,, re-plugged your paths in carb.

Drain tank, then rinse w/ one gallon, and drain again, clean carbs again... OR, add a cheap plastic fuel filter,, then re-clean the carbs again,, and start it.
 

·
Registered
Joined
·
1,189 Posts
put some injector cleaner in there and change out your plugs ,if still no lick the carbs idle cct will have to be manually addressed
 

·
Registered
Joined
·
2,375 Posts
Some need to remember this gas we get now days and most with ethanol when the sled is stored near empty on fuel it will draw more moisture and also goes bad faster.No ethanol for storage if ya can and seafoam is your friend.And ya ya ya some will say there are better products and all i can say is this has worked for me for years with all different kinds of motors in storage,,2 stroke and 4 stroke from stockers to racers and never had a issue.Ethanol and storage = bad news but it is what we have to deal with..
 

·
Registered
Joined
·
3,771 Posts
I would be pulling the carbs off again, remove the pilot jets and the fuel screws, clean out the pilot circut with carb cleaner and compressed air, clean pilot jet with a small wire or, a torch tip cleaning wire being carefull not to force it in. Check main jet the same way. Check needle valve and seat for dirt or obstructions. While you have the carbs off i would be checking the reeds for cracking and chipping and the rubber boots for cracks, sounds like you could also be pulling in air somewhere. When installing carbs make sure there are no pinched lines and that all connecters are plugged in. Make sure the choke cable setting is correct, make sure the plungers are returning all the way back after releasing the choke lever. Almost for got, the fuel screw setting should be one and a half turns out. New gas and plugs and hopefully your ready to go. Good luck.
X2 , I would highly recommend new pilot jets! They are inexpensive ! And hopefully you don't need reeds or carb boots!
 

·
Registered
Joined
·
1,201 Posts
Might have small amount of crap in tank,, re-plugged your paths in carb.

Drain tank, then rinse w/ one gallon, and drain again, clean carbs again... OR, add a cheap plastic fuel filter,, then re-clean the carbs again,, and start it.
That'd be my guess as well. Replacing parts is foolish since it ran fine, then allowed enough fuel to be ran through the carbs to collect more crap and again plug things up.
 

·
Registered
Joined
·
244 Posts
If your sled only a has a couple gallons of fuel and on the stand (rear elevated) it can starve and slowly die and fool you. Mine does that when I try to run it with very low fuel on the stand.
 

·
Registered
Joined
·
811 Posts
Discussion Starter · #14 ·
Well out of laziness I bought some seafoam drained the tank bought 5 gallons of 91 from a station down the street ethanol free and dumped it in. Tried to fire it a couple times with no luck... Took some tips from my dad and started wiggling wires to the kill switch and other electronics and gave it another shot and it fired right up... Warmed it up for 5 mins and then gave it gas and it ran fine... Unfortunately now I don't know if it was electrical now or the gas..... It fired for the rest of the day and revved up and back down fine... Wiggles wires trying to see if it could cause a problem and nothing so hopefully problems are through but I'm skeptical. Ill keep starting it for the next few days and see what happens.
 

·
Registered
Joined
·
1,463 Posts
If your sled only a has a couple gallons of fuel and on the stand (rear elevated) it can starve and slowly die and fool you. Mine does that when I try to run it with very low fuel on the stand.
Been there, done that. I'd put my money on stillimpin's diagnosis. If you saw the inside of a XP gas tank you would know why they act like they do on a test stand. We have customers do the same with cars, tow them in because they broke down, we add fuel and they run perfect. Always check the simple things first ! Good Luck !
 

·
Registered
Joined
·
811 Posts
Discussion Starter · #17 ·
Haha yeah thanks everyone. I'm gonna keep an eye out for an electrical gremlin but for now things seem to be good. It only had 2-3 gallons at most of gas so I think what was left in the tank was just nasty after sitting all summer between water vapor in the tank and what not. if I can recall correctly the last time I gassed last winter was from a trail stop gas pump that doesn't get much business so that coulda been old gas as well. The seafoam seemed to work great so thanks for that tip!!! I think now it was combination of bad gas, low fuel, and being on the stand. Ill report back if things head south again.
 

·
Registered
Joined
·
1,201 Posts
Haha yeah thanks everyone. I'm gonna keep an eye out for an electrical gremlin but for now things seem to be good. It only had 2-3 gallons at most of gas so I think what was left in the tank was just nasty after sitting all summer between water vapor in the tank and what not. if I can recall correctly the last time I gassed last winter was from a trail stop gas pump that doesn't get much business so that coulda been old gas as well. The seafoam seemed to work great so thanks for that tip!!! I think now it was combination of bad gas, low fuel, and being on the stand. Ill report back if things head south again.
Good thing you just didn't start replacing carb parts like some suggested. To find out that wasn't the problem.
 

·
Registered
Joined
·
2,375 Posts
Good thing you just didn't start replacing carb parts like some suggested. To find out that wasn't the problem.
X2..... keep it simple to start with..Lots of parts get replaced because people dont do this. The little things get over looked and over thought.
 
1 - 20 of 31 Posts
Top