Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,400 Posts
I am new here so if this has been talked about I am sorry.

I would say that I ride normal not hard and not easy. I got about 8 MPG on my trip this weekend. Had a buddy with an F7 with a big bore kit and he would use about 2/3 the fule that I would. I did change plugs and they were very black with a little crap on them like there is carbon building up.
Could it be the DPM not working? Seems to run good.

Any ideas? Thanks for the help.

Rocketboy
 

·
Registered
Joined
·
351 Posts
I had this problem with my 04 800X Renegade. My gas tank vent was plugged and the machine was running fair but still pig rich. Drilled out the gas tank vent now the plugs are nice and tan and I only use a little bit more gas than an 05 PTech 800 Renegade.

You did not say what year your sled is. Check the Ttabs post in the mountain section and they have pictures how to fix this, or do a search for gas tank vent.
 

·
Registered
Joined
·
712 Posts
Make sure all your dpm (what ever its called now) are all hooked up around your carbs.Do a seach some one ahd the same problem and found a small hose that was not hooked up.He had pics of it .Good luck.
 

·
Registered
Joined
·
2,705 Posts
My REV is also a pig on fuel. The 04 800HO leaves a black smoke trail in the snow when it takes off.

Ran out of fuel - dumped in the 13 Liter Caddy - and ran out again at 34 km.

Plugs are a light chocolate brown.
I'm running 390/390 jets, and lifted the needles one notch because we are travelling so far on the the trails this year. Don't want a mid range burn down.
No logging, so no snow plowing on the roads.

So how would a plugged vent on the gas tank make the DPM go rich???
The tank would build low pressure and make the fuel pump work harder for sure, but why rich??

Curious.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top