Ski-Doo Snowmobiles Forum banner
1 - 13 of 13 Posts

·
Super Moderator
Joined
·
31,547 Posts
They're not. Check out the results from this extremely UNscientific poll conducted on the gernral forum side. Click away! You'll see here it's 15%. While that is way too many, how many people on 800PT's are not on this forum. I know of 2 that run flawlessly and those guys are not DooTalkers. As with everything, you hear more about the problems than you do about the flawless ones.
 

·
Super Mega Wicked Advanced Member
Joined
·
2,041 Posts
MX-Z Man said:
They're not. Check out the results from this extremely UNscientific poll conducted on the gernral forum side. Click away! You'll see here it's 15%. While that is way too many, how many people on 800PT's are not on this forum. I know of 2 that run flawlessly and those guys are not DooTalkers. As with everything, you hear more about the problems than you do about the flawless ones.
[snapback]700470[/snapback]​
Scientific no, but still a snap shot of what is going on.

There are also a lot of guys having engine failures that arn't on here. My buddy has gone thru 3 engines in 4500 miles and he's not on the internet.
 

·
Registered
Joined
·
40 Posts
Statistically I think they are not going down as much as you think. The only ones complaining are those that had a problem. I would bet 1/2 of all incidents are people not taking care of their stuff. Mine went down, but I had a clogged main jet line, and that was covered by doo. Overall I am impressed and would not think of getting anything else.
 

·
Registered
Joined
·
305 Posts
Caleb said:
Every were i look i here something about the 800's(04-06).I keep hearing that they are blowing up.Is this true and why are they doing this?

[snapback]700454[/snapback]​
0025 p tech 800 , 4000 plus miles, not a glitch. i didnt modify it to make it faster.
i dont hold it open for 3 miles on the lakes, not a lake racer.

great fuel mileage,runs like a swiss watch, lots of grunt.
i allways warm it up properly, run iso religously,and run 6 onces of oil per tank .
really couldnt be much happier.
 

·
Registered
Joined
·
249 Posts
Caleb said:
Every were i look i here something about the 800's(04-06).I keep hearing that they are blowing up.Is this true and why are they doing this?

[snapback]700454[/snapback]​
Are you jealous ? I owned a 800HO 2004, 8500KM, I have never had a problem with this. Doo is rock !!!!!!!!


Good luck with your POPOPOPOPOPOPO!!!!!!!!!
 

·
ITs WINTER!
Joined
·
7,500 Posts
2350km on mine since dec17 and not a single hickup yet!

My old yami would have done 3 motors by now...
 

·
Registered
Joined
·
62 Posts
MY BASE GASKET SEAL WENT TAKING OUT THE WHOLE ENGINE AT ABOUT 1500 MI, GOT IT BACK TODAY, MY SKIDOO TECH SHOWED ME MY CARB BOOTS WHICH ARE BEGINNING TO CHALK, SAYS THESE WILL SEPARATE SOON, OF COURSE, THE BOOTS ARE ON BACK ORDER, I BELIEVE THEY ARE SWITCHING VENDORS.

CHECK YOUR CARB BOOTS, Y PIPE BOLTS, AND IF YOUR ENGINE DOESN'T IDLE DOWN RIGHT AWAY GET IT OFF THE TRAIL AND GET IT CHECKED.
 

·
Registered
Joined
·
90 Posts
KRAZY DOO said:
... AND IF YOUR ENGINE DOESN'T IDLE DOWN RIGHT AWAY GET IT OFF THE TRAIL AND GET IT CHECKED.
[snapback]701610[/snapback]​
I'm curious about this. My '02 800 did this forever, it now has well over 11,000 k with no problems. My '06 PT did this on the first ride. I've only been out the one time (@!#%* winter) with just 140 k. Should I be worried? I was just going to bring the idle screw back a bit because it seems to have loosened up a little and now idles at 1800. But it was taking 10 secs or so to return after a brisk run. Gonna trailer out this weekend for a four day run. Oil consumption on mine seems a bit high actually but not enough miles to really know yet.
 

·
Registered
Joined
·
6,393 Posts
Do not set the oil pump leaner, if anything set it richer, these big twins need lots of oil to survived. Or better het mix a little oil with your fuel, my doo salesman recomends this for the life of the engine. The injection system, injects oil into the crank case where it is then mixed, this system doesn't oil the intake side of the piston or main rod bearings very well, so the premix takes care of this .
The high idle speed can be fixed by fripping the choke on a couple of times when you come to an idle. P.S. 5500km no engine failure yet.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top