Ski-Doo Snowmobiles Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
636 Posts
Discussion Starter · #1 ·
Sled is an 05 Early release Renegade w/ ~3.2k. Stock motor w/ an s6x kit. Haven't has this problem before w/ the sled not starting on the second pull, always starts on second pull. So we were up at the hill this weekend and it took about 10 pulls to start the sled. That wasn't a huge deal(just thought it was plugs), but now every time I put it into reverse it stalls, when the seld is warmed up etc., always stalls. Been having this problem a little last year and beg. of this year, but it was few and far between. The sled still runs good, still has excellent midrange. It's def. not the plugs, they were a nice gold-ish color and I even switched to another new set. I can only guess it has low compression....and needs a rebuild! I got the 2 yr. warranty, btw. Just wanted to hear some of your opinions....Ima gonna have to go grab a comp. tool off my buddy. What the proper way to conduct the test and what rnage should the engine be within. I'll post back up tom. w/ some numbers.
 

·
Registered
Joined
·
3,120 Posts
Flaking rings do a leak down test..
 

·
Registered
Joined
·
739 Posts
doo u have ele start ? wierd thing is my bro does on his and when the sled was put into reverse it would die too, replaced the batt and all was well. we also did a leak down and comp test and everything was ok.
good luck
ckoz
 

·
ITs WINTER!
Joined
·
7,497 Posts
Sounds like low compression...
 

·
Registered
Joined
·
1,484 Posts
Bring it in for rings. Mine was hard to start the day it sucked the mag side piston out of it and the compression was starting to drop off that was at 5500miles. Back together and running great, starts first pull and doesn't stall going into reverse.....
 

·
Registered
Joined
·
205 Posts
needs rings. just had my 04 done same symptoms. depending when you purchased it, it maybe still under warranty. your dealer should get it taken care of anyways
 

·
Registered
Joined
·
826 Posts
Mine did it also. compression was 150 each side at 2200 miles. It was a bad fuel relay! Sometimes it would start 2 pulls, then it took 10. Stalled in reverse. Check the relay!!
 

·
Registered
Joined
·
1,209 Posts
I have 3600 miles on my Ltd 05 Gade and compression is exactly the same as when new! Does this mean that you don,t need rings,NO but it could be something else.Have you checked the TPS adjustment,they doo go out of adjustment and have similar symptons.Mine did,do you have excessive play in your throttle cable,more than 1/16 inch,is your oil pump sticking half open,mine did and caused starting issues until i added an extra return spring.Just other ideas before digging into the motor.Hardcore sledder has same sled and has done over 13000 miles on those moly rings with no problems .
 

·
Registered
Joined
·
44 Posts
i had a 04 600 ho at about 1800 to 2000 miles it had the same problem would not start worth a f%$# when warm, and would stall going in to reverse. i checked the commpression and it was right around 105 on both sides. which is really low. they should be around 135 to 145 with that milage. so i would have to say you have low commpression.
 

·
Registered
Joined
·
636 Posts
Discussion Starter · #12 ·
BOBLER said:
rings are shot, case closed
[snapback]753633[/snapback]​
That's what I thought, where's this fuel relay, I was messin w/ the fuses, nothing wrong there....The sled still has 2nd year engine warranty till Nov. 06. The weird thing is started the sled in the morning fine, rode from Winola Forest to pulaski, sled still started fine, rode to Redfield for gas and food. After that won't start well and stalls in reverse, but once started runs fine.....
 

·
Registered
Joined
·
93 Posts
You all can yell rings all day but check the basics first. The SDI relies on that small battery to power up the system rather than a true batteryless system like AC uses etc. Check to see that the battery is fully charged....My '05 just sat for one summer and the battery was no good and did the same exact thing that you are explaining here. Be sure to check that as well.
 
1 - 13 of 13 Posts
Top