Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
I posted in different topic yesterday about my 2006 SDI Renegade going into the famous "limp" mode after about 3 minutes of a 65 mph run up toward Cook Minnesota. After about 3-5 minutes or so, I started it up and it ran perfectly for the rest of the day. This is the ony time it has happened in the 1000 miles its been run. I probably have avoided the extended run at this speed due to the posts on Dootalk about the overheated exhaust can.

I took the sled into my dealer on Monday and was told yesterday that there are no remapping codes from Skidoo. Supposedly my sled had any updates performed prior to shipping. The advice was to vary the throttle settings.

I need some help. Does anyone have a specific bulletin number I can refer to concerning this issue? The 600 SDI is the most impressive engine I've seen in a snowmobile and its difficult not to like power and fuel efficiency. Starting the sled at minus ten degrees is so easy while everyone with carbs is struggling to keep their machines running.

However, some lake runs and wide long and smooth trails require a sled to be able to cruise at 60 - 65 without adversly affecting the engine. If I was running at wide open throttle for 5 minutes perhaps I would understand the engine going into a safe mode to avoid damage. A 115 hp engine should be just "loafing" at 60 mph.

If anyone has something specific from their dealer I would appreciate the information.
 

·
Registered
Joined
·
809 Posts
i brought mine to the dealer yesterday to have this update done. its still there, but i was in the office while he was looking for the update on the boss website. it isnt showing up on the boss website, but i guess the latest update for the scanner has the latest 600sdi fuel map.
 

·
Registered
Joined
·
676 Posts
The only 06 mapping I've heard of is for the 05 engines to get the 06 engine mapping. When I asked my dealer about it he said it was for 05's that had fouling issues. So there's no 06 remapping for an 06 engine, that I know of.
 

·
Registered
Joined
·
809 Posts
Offshore24 said:
The only 06 mapping I've heard of is for the 05 engines to get the 06 engine mapping. When I asked my dealer about it he said it was for 05's that had fouling issues. So there's no 06 remapping for an 06 engine, that I know of.
[snapback]740936[/snapback]​
check this thread out HERE, some people have the new map for the 06 installed. it fixes the sled going into limp mode after a long run at a certain rpms, and takes care of the glowing can.
 

·
Registered
Joined
·
15 Posts
Go to a different dealer! I experienced the same problems on my 06 gade and the remap fixed it. helped out fuel mileage also.
 
1 - 5 of 5 Posts
Top