Ski-Doo Snowmobiles Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
Hey guys, I recently picked up a slightly used (1200 miles) 2014 550f skidoo renegade. I owned a 2008 550f gtx a couple years ago so I am familiar with the engine but this one is acting strangly. I live in the high arctic and this machine is my family car. We use it to go to work, take the kids to school, groceries as well as playing on the weekends and extended hunting/fishing trips. It gets run everyday. I keep it in an unheated outbuilding. My old gtx had to warm up for about 5 minutes then it ran fine. This one after even ten minutes idling it still sounds like it is not running fully on both cylinders. It is running rough. It leaves quite a black patch in the snow. If I hop on and go, it bogs, misses and sometimes backfires until it is fully warm, then it runs like a top. I just checked and replaced the plugs. The one on the clutch side was pretty gunked up/black. I put in NGK 3194 br9e6 plugs (did not gap them as I did not have my gapping tool yet) and this helped a bit but it is still an issue.

It is cold here (-28 celcius) already and it does get down to -50c. The skidoo 550F is one of the more saught after machines up here because they are so reliable, light and easier to work on.

So, besides checking the gap on it (this next weekend, along with a belly pan and heavy duty hitch install), any thoughts? Maybe a higher quality plug? I realize I could let it warm up longer, but that is not always a reasonable possibility.

Thanks all!
 

·
Registered
Joined
·
390 Posts
I would definetely have the carbs cleaned. Mine did something similar and after i had the carbs cleaned it ran and idled great

The 550f is a fun sled
 
  • Like
Reactions: captainkf

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
Mosinee, did you clean them yourself? I have yet to get too far into the engine on my machine and have not done anything to the carbs. How hard is it to get in there? It seems like a lot of plastic must come off first...
 

·
Registered
Joined
·
390 Posts
I took it to a dealer
 

·
Registered
Joined
·
4 Posts
I had a very similar problem with my 2014 550f GTS. Backfire/bogging in mid-low range rpms. Thought it was running lean, but it turns out one side was running too rich and flooding. Cleaned the carbs and put 190 pilot jets on both sides (came with 200 on one side and 190 on the other). It's running great, but going to check the plugs after a bit to make sure i'm not running too lean. Being in Nunavut there's lots of little tricks we need to learn that guys down south don't have to deal with. I hope you got this figured out!
 
1 - 5 of 5 Posts
Top