Ski-Doo Snowmobiles Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I have a question for you guys. My mxz 700 starts in 3 pulls with full choke when cold, pretty normal. However, when it has been run for a while like on the trail and we shut it down, it takes 3 pulls to get it running again. On the third pull, it idles up pretty slowly, as if it is starting on 1 cylinder and then the other cylinder kicks in once it's running. Have you ever heard of this and what do you think the issue is? Last year, I rebuilt the top end because the base gasket was leaking coolant and it would lose power when pushed to a high enough rpm. I just replaced the gaskets, not the pistons. It also needed 3 pulls to start when warm before the rebuild.

I'm guessing something in the ignition system needs to be replaced to fix this issue. I'm looking for more input. Thanks for your help
 

·
Registered
Joined
·
635 Posts
not sure if it'll have anything to do with it, but does it have liquid heated carbs?

I notice mine takes an extra pull or two when I have the valve turned on....vs one pull when the valve is closed.
 

·
Stay to the right, in your lane and slow down.
Joined
·
1,526 Posts
Could be ignition CDI perhaps. When was the last time the carbs were thoroughly cleaned. perhaps something is sticking like a float or slide and flooding the engine a bit when you shut down?
 

·
Registered
Joined
·
35 Posts
Could be ignition CDI perhaps. When was the last time the carbs were thoroughly cleaned. perhaps something is sticking like a float or slide and flooding the engine a bit when you shut down?
The carbs havent been cleaned since we bought it in 2011. Is there a video on how to rebuild and clean these carbs?

I will check the shut-off valve for the carb coolant flow. I think it is off, or it should be at least.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #7 ·
Right after i typed my first response, I did a youtube search and watched that exact same video lol. Thats a good place to start
 

·
Registered
Joined
·
1,604 Posts
X 2 on full throttle on restarting a warm sled. I believe it is due to the fuel in the carbs expanding into the intake due to the heat of the warm engine. Every Doo I have owned has been like this, not so on the fuel injected sleds though.
 

·
2nd Whore in command
Joined
·
102,201 Posts
Compression test and clean the carbs if not already done? Very rarely do I need to hold the throttle on a warm engine.....mines a 600 though with round slide carbs? When it's upside down it takers a few pulls lol
Choke plungers clean and working good?
Really 3 pulls without choke after a run and cool down doesnt sound odd too me?
 
1 - 11 of 11 Posts
Top