Ski-Doo Snowmobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
370 Posts
Discussion Starter · #1 ·
i have been messing with this sled here and there trying to get it back to a running and driving state. after tearing its engine all down and going thru it all i got it back together in the sled and carbs ready to go. i go it running but the mag side isn't getting spark. it seems to intermittently once its running if you can get it to stay on. but i don't really want to run it like that as i am sure its washing down the cylinder. is there any options available to upgrade the ignition. it has the original polar fire on it. i read a bunch on this a year ago when i started the project but can't find any of that info. thanks!!
 

·
Have been
Joined
·
5,940 Posts
i have been messing with this sled here and there trying to get it back to a running and driving state. after tearing its engine all down and going thru it all i got it back together in the sled and carbs ready to go. i go it running but the mag side isn't getting spark. it seems to intermittently once its running if you can get it to stay on. but i don't really want to run it like that as i am sure its washing down the cylinder. is there any options available to upgrade the ignition. it has the original polar fire on it. i read a bunch on this a year ago when i started the project but can't find any of that info. thanks!!
Have you tryed a real hot plug?, The polar fire was not known for great durabuilaty but most times it will work cold then miss when it gets hot ! I raced a 245 rv back in the day and I burned 4 ignitions in the first season . Then we found out the 9500 rpm it needed to make the sled Go fast with the pipes on was more than the stock poler fire could take . My sled would pull hard for 3 laps then drop one lung when the ignition got hot. the only cure was to change the box.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #3 ·
its got br9es's in it. its not to the point where its hot. i only ran it for a minute cause i knew something was wrong.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #4 ·
is there any write ups on converting it to a newer style ignition? i found a 86 citation local for super cheap. don't know if that would help at all.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #5 ·
Nobody can help me out on this? Seems to be a common issue. But no way to resolve it? I have tried searching on the forum but I don't know if I am just not putting in the correct wording or what.
 

·
Registered
Joined
·
821 Posts
The after market Taiwan CDI will work on your 76 stator for normal trail riding. Just check to be sure it is timmed correct. I have a friend has one on his 77 and it runs ok. There are bosch CDI's around. When I saw your add I checked right away with the vintagesled.com guy that had the cdi's for sale and he said they were already gone. The nipondenso conversion is possible but you should be able to come up with a bosch cdi. Sometimes I have waited two years for the right part to come along.
 
1 - 8 of 8 Posts
Top