Ski-Doo Snowmobiles Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2016 ski doo mxz blizzard 800r etec that is giving me issues with starting after an engine rebuild. It has great spark, 140 compression and is getting plenty of fuel. I also changed the plugs several times. It fires when i crank it but doesnt stay running. It backfires when you hold the throttle. I am desparately needing suggestions.
 

·
Keeping Skioutty on his toes...
2017 Ski doo Renegade 900...2022 Polaris Indy 137 XC 650
Joined
·
31,332 Posts
Throttle sensors might need to be adjusted...
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Yes the right coil is to the right plug. yes the reeds are good. I checked throttle sensors. Still does the same. Anyone else?
 

·
Keeping Skioutty on his toes...
2017 Ski doo Renegade 900...2022 Polaris Indy 137 XC 650
Joined
·
31,332 Posts
Crap gas... Fuel pump PSI... Fuel filters... Dirty injectors... And I think the TPS has to be adjusted on buds... Exhaust valves stuck or not calibrated...
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Bought a new crank, and did a top end. Also bought new cylinders, Im thinking of buying the buds system. But ill probably end up taking it to the dealer as it wont get here on time.
 

·
Premium Member
Joined
·
27,934 Posts
Congrats. Crank + top-end = awesome!

It's only July 30th, so BUDS should arrive weeks if not months before it is time. Having BUDS is awesome, but it is only a small part of the overall grand picture. Everything needs to run right to get the added reliability which also translates to an added performance. Build yourself a list for both and find which ones can do both.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
Do any of you guys had experience with buds, and what i might be glad for with the buds software?
 
1 - 12 of 12 Posts
Top