Ski-Doo Snowmobiles Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
1,985 Posts
I have a 2016 XRS 800, and while riding it seems when I stop for a bit and then try to restart it, it takes a bit to start? Anyone else seeing problem. Normally, at first start it fires right up, but not the same when warm. Any thoughts!

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,985 Posts
Discussion Starter · #4 ·
Yeah, my 2014 started very easy. This one seems odd? It's direct injection, should have to open the throttle any, I would guess?
Wonder why it's doing this? Going to bring it in for the after break service, hoping they can figure it out?

Sent from my iPhone using Tapatalk
 

·
old ski-dool
Joined
·
3,313 Posts
I have read somewhere.....here maybe.....to change plugs after break-in.

Mine starts great cold or warm. I don't think the crank gets 1 revolution on it and it fires right up.
 

·
Registered
Joined
·
1,985 Posts
Discussion Starter · #7 ·
No. It runs great, never heard any backfire or anything. Once started it runs just fine. Just doesn't seem to start right away like my 2014 did

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
400 Posts
When it doesnt start the first time, do you play with the teather? My buddies BCX is the same way, jiggels the teather and it fires right up
 

·
Registered
Joined
·
889 Posts
Are you giving it a really hard pull? Mine needs a really good pluck to start first pull, I'd say it's harder to pull over than my 99 mach Z.
 

·
Registered
Joined
·
1,985 Posts
Discussion Starter · #10 ·
No it's got E-start, it just seems to crack over longer then my 2014 did? When it sits all
Night and I go to start it, it fires up right away. Ride for awhile, then try and restart it, it cracks longer. That's the issue I'm seeing.

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
39 Posts
I had the issue on my new 16 summit. I didn't have e start and it would take me like 15 pulls to start it after I had been riding it for awhile. I took it back to service and they said there was a computer flash for alititude hot starts. I have since not had an issue and also installed electric start.
 

·
Registered
Joined
·
23 Posts
My '16 freeride does the same thing. When hot usually have to hit the starter twice to get it to fire, but still turns over quite a bit. If it sits overnight it doesn't even make two rotations and it's running. Dealer mentioned the comp re-flash and is checking into it, but the altitude I've had it in isn't over 1,500'

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,985 Posts
Discussion Starter · #13 ·
When I bring it in for the first service after break in, I'll have them go through that and hopefully they will clear it up with the re-flash? thanks for all the replies, much appreciated.
 

·
Registered
Joined
·
3,629 Posts
Mine fires up instantly weather cold or hot.

Are u riding in the mountains?

Also do u let it idle a little before u shut it off. If u come off a fast pull and then hit stop maybe that could have something to do.with it

I always let mine was idle for a minute or so before shutting down
 

·
Registered
Joined
·
23 Posts
Dealer called brp and they told them to check fuel pressure first being there's apparently some with bad fuel pumps... It's going in next week after the trip to the U.P. this weekend.

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,985 Posts
Discussion Starter · #16 ·
Dealer called brp and they told them to check fuel pressure first being there's apparently some with bad fuel pumps... It's going in next week after the trip to the U.P. this weekend.

Sent from my iPhone using Tapatalk
Oh wow, please let me know what they find out? I would hate to be riding far from home and have that go out. Very interesting Thank you
 

·
Registered
Joined
·
460 Posts

·
Registered
Joined
·
460 Posts
Thank you very much, this is VERY helpful, it's nice to know at least i'm not alone on this issue. Hope to get mine into the deral as soon as I can, and get this issue resolved. Thanks again
No problem.
 
1 - 20 of 23 Posts
Top