Ski-Doo Snowmobiles Forum banner
81 - 93 of 93 Posts

·
Registered
Joined
·
2,262 Posts
Yes the last sequence of numbers on the VIN is the production run number
 

·
Registered
Joined
·
213 Posts
Might see better in this picture. I think it's the correct spot. Only difference the bulletin shows the dots on the other outer edge on the motor while mine are more towards the center.
 

Attachments

·
Registered
Joined
·
213 Posts
I don't see any dots on that location. Read the bulletin again and I see no dot no further action required so I should be good to go.
 

Attachments

·
Registered
Joined
·
10 Posts
my sled is a 2014 sp 154 bought December 30th 2013. At 1768 km the cel light came on after the sled was running rough and back firing, before it did this it wouldn't rev over 6000 rpm. the code 1477 was displayed which is rave valve not closed. i took it to the dealer and he claims he found a disconnected hose and that was my problem. Today i took it out and it did it again. Ran good for a half hour then wouldn't go over 6000 rpm, started back firing and displayed 1477 cel code. got it back to blue called the dealer at RTR and he wants me to take it back. After finding this thread mine has no dots that i can see, but has number 409, im gonna assume that my raves are toast, and demand the recall.
 

·
Registered
Joined
·
10 Posts
Just booked my sled at the dealer today, getting my rave valves replaced on my 2014 summit under the recall at 5000 km. Sled was running like crap asked the dealer if there was a recall still on it because of this thread, thanks.
 
81 - 93 of 93 Posts
Top