Ski-Doo Snowmobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Sled ran wonderful all weekend long and Sunday right at the end of the day it started running like crap. I drained the gas today and filled it with new gas which helped with the really low idle it started having at the end of the day. Now when it idles and i hold it to the bar from idle it bogs and dies. I've cleaned the rave valves checked the Dpm with a 9 volt battery and that is working. What else could it be!?! Carbs seem okay but haven't taken them apart to check if anything is in there. Ran out of time today.
 

·
Always wrenching on toys
Joined
·
1,477 Posts
i would start with a compression test and a good carb cleaning, then go from there.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #4 ·
Haven't gotten to the carbs yet but the boots looked fine. If I don't hold it to the bar off idle and take off normally and nail it once I'm moving it takes off like a rocket and that kinda tells me it had good compression. Could it be something in my pilot??
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
Reeds could be it now that I think about it. That would also explain my weird idle I have. It goes from 1800-2000 to 1400-1600 up and down. And when I hammer it there is to much air getting into the engine and bogging out??
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
Well it was just a thought I guess. And I have heard of the reeds chipping or cracking at any time so I will try to investigate them tomorrow.
 
1 - 7 of 7 Posts
Top