Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I know the guy’s with the Mach’s have been having ECU problems, but how about the 06’ 600 SDI’s? I have an 06’ MXZX 600 SDI that my wife usually rides and yesterday evening we were making a hard run across the flowage and after the run the sled was sitting there, idling, and spitting blue flames out the exhaust about every 2 to 3 seconds. I had noticed earlier that this sled will just scream to about 90 then it just seams like it slams on the breaks……… ???????????
 

·
Registered
Joined
·
105 Posts
Welcome to the wonderful world of SkiDoo SDI motors......

I understand you beat a Mach Z to the bar at the other endo of the lake. Man, your 800 must really run!
 

·
Registered
Joined
·
465 Posts
REVDocker said:
I know the guy's with the Mach's have been having ECU problems, but how about the 06' 600 SDI's? I have an 06' MXZX 600 SDI that my wife usually rides and yesterday evening we were making a hard run across the flowage and after the run the sled was sitting there, idling, and spitting blue flames out the exhaust about every 2 to 3 seconds. I had noticed earlier that this sled will just scream to about 90 then it just seams like it slams on the breaks……… ???????????
[snapback]699493[/snapback]​
I have the same sled and it does the same thing with the flames and so does my buddies sled, they run great so I am just gonna run it, BURN BABY BURN!!!!!!!!
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
BeechBoy said:
Welcome to the wonderful world of SkiDoo SDI motors......

I understand you beat a Mach Z to the bar at the other endo of the lake. Man, your 800 must really run!
[snapback]699896[/snapback]​
I turned on my "Snow Screen" and blinded him..........the guy driving was a little old anyways... Hey Beech................... Did you find that theater near Mercer that was playing Broke Back Mountain!
 
1 - 5 of 5 Posts
Top