Ski-Doo Snowmobiles Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
588 Posts
Discussion Starter · #1 ·
I took this out and rode it and got 12 miles to the gallon. Then on the way home I stopped at the dealer and had them run the VIN. They said the updates were not current. So I left it there and called them a few days later and they said the updates were done just not updated in the BRP system. They adjusted the oil cable and said the rave cable wasn't routed right and one valve wasn't opening all the way. They fixed that too. No charge. The next time I rode it with a friend who has the same machine the engine started rattling and I ran out of gas at 52 miles. It sounds like that inherent rattle on a two stroke dirt bike. I couldn't see where any gas was leaking and I couldn't smell any either. Is this 'RATTLING" anything to be concerned about? What would cause this kind of fuel consumption?
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #2 ·
Boondocker-1 said:
I took this out and rode it and got 12 miles to the gallon. Then on the way home I stopped at the dealer and had them run the VIN. They said the updates were not current. So I left it there and called them a few days later and they said the updates were done just not updated in the BRP system. They adjusted the oil cable and said the rave cable wasn't routed right and one valve wasn't opening all the way. They fixed that too. No charge. The next time I rode it with a friend who has the same machine the engine started rattling and I ran out of gas at 52 miles. It sounds like that inherent rattle on a two stroke dirt bike. I couldn't see where any gas was leaking and I couldn't smell any either. Is this 'RATTLING" anything to be concerned about? What would cause this kind of fuel consumption?

[snapback]742662[/snapback]​
I wonder if the dealer
adjusting my oil cable had anything to do with it?
 

·
On the prowl for POW
Joined
·
1,254 Posts
Boondocker-1 said:
Boondocker-1 said:
I took this out and rode it and got 12 miles to the gallon. Then on the way home I stopped at the dealer and had them run the VIN. They said the updates were not current. So I left it there and called them a few days later and they said the updates were done just not updated in the BRP system. They adjusted the oil cable and said the rave cable wasn't routed right and one valve wasn't opening all the way. They fixed that too. No charge. The next time I rode it with a friend who has the same machine the engine started rattling and I ran out of gas at 52 miles. It sounds like that inherent rattle on a two stroke dirt bike. I couldn't see where any gas was leaking and I couldn't smell any either. Is this 'RATTLING" anything to be concerned about? What would cause this kind of fuel consumption?

[snapback]742662[/snapback]​
I wonder if the dealer
adjusting my oil cable had anything to do with it?
[snapback]742856[/snapback]​
If you're running a Dynoport can get rid of it. I've had 2 go bad this year 500 miles
you may have a stuck injector as for the rattling and or exceesive fuel guzzling
You could try disconnecting 1 injector at a time to try and isolate it
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #4 ·
diamond dave said:
Boondocker-1 said:
Boondocker-1 said:
I took this out and rode it and got 12 miles to the gallon. Then on the way home I stopped at the dealer and had them run the VIN. They said the updates were not current. So I left it there and called them a few days later and they said the updates were done just not updated in the BRP system. They adjusted the oil cable and said the rave cable wasn't routed right and one valve wasn't opening all the way. They fixed that too. No charge. The next time I rode it with a friend who has the same machine the engine started rattling and I ran out of gas at 52 miles. It sounds like that inherent rattle on a two stroke dirt bike. I couldn't see where any gas was leaking and I couldn't smell any either. Is this 'RATTLING" anything to be concerned about? What would cause this kind of fuel consumption?

[snapback]742662[/snapback]​
I wonder if the dealer
adjusting my oil cable had anything to do with it?
[snapback]742856[/snapback]​
If you're running a Dynoport can get rid of it. I've had 2 go bad this year 500 miles
you may have a stuck injector as for the rattling and or exceesive fuel guzzling
You could try disconnecting 1 injector at a time to try and isolate it
[snapback]743332[/snapback]​
How would I know if the can went bad? How can I tell if a injector is stuck?
 

·
Registered
Joined
·
1,624 Posts
Are you sure its in the engine and not the chaincase? Had a link go out and everytime it rounded it would rattle on mine the other day. Take off the belt and run the engine to try to hear exactly where its coming from.
 

·
sledhead
Joined
·
2,241 Posts
Do you have a HPS can??

If so, remove the loose junk in the top baffle, then call HPS and compalin, not that it matters
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #9 ·
sharky74 said:
Are you sure its in the engine and not the chaincase? Had a link go out and everytime it rounded it would rattle on mine the other day. Take off the belt and run the engine to try to hear exactly where its coming from.

[snapback]744809[/snapback]​
I am running a dynoport can. This rattle is heard at idle. When you stand back and listen it sounds like a knock. I have tried to isolate it and the rattle (knock) seems to be coming from the bottom front of engine compartment if you get down on the ground under the belly. When you get into the engine compartment it sounds like more of a rattle and is prominent in the RAVE valve chanel in front of the clutch side cylinder. Thinkin about taking it to the dealer.
 

·
Registered
Joined
·
411 Posts
depends on how many miles but you might check the rollers in the primary. mine sounded funny so I took it apart and 2 rollers were stuck and were wobbled out alittle.
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #11 ·
s.e.xtreme said:
depends on how many miles but you might check the rollers in the primary. mine sounded funny so I took it apart and 2 rollers were stuck and were wobbled out alittle.
[snapback]746314[/snapback]​
Never would have guessed clutching but it can't hurt to check. I have just under 800 miles on machine.
 

·
Registered
Joined
·
13 Posts
my friends rt was making that noise. Shortly after it started making the noise it broke a skirt off the piston and pushed it out the bottom. Mine is starting to make the rattle. It kind of sound like worn out buttons in my clutch. I believe the skirts are weak. The dealer thinks this is going to be a problem with collapsing skirts.I hope not
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #13 ·
Okay,
went to the dealer today after filling with gas. Started it up and NO knock. Dealer said it was a "LEAN KNOCK" that happens when you are low on fuel and there isn't enough pressure in the tank. okay. He must be right cause it didn't knock all day. Now for my next trouble spots: 1. When I roll up to a stop the engine idles down and shuts off. Pull the rope it sarts right up. 2. I ran out of gas at 52 miles and my friend didn't (same machine). when we filled up we both took 7 gallons. It appears that I have a 7 gallon tank! Didn't know they made one. Does anyone know anything about this?
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #17 ·
diamond dave said:
Boondocker-1 said:
Boondocker-1 said:
I took this out and rode it and got 12 miles to the gallon. Then on the way home I stopped at the dealer and had them run the VIN. They said the updates were not current. So I left it there and called them a few days later and they said the updates were done just not updated in the BRP system. They adjusted the oil cable and said the rave cable wasn't routed right and one valve wasn't opening all the way. They fixed that too. No charge. The next time I rode it with a friend who has the same machine the engine started rattling and I ran out of gas at 52 miles. It sounds like that inherent rattle on a two stroke dirt bike. I couldn't see where any gas was leaking and I couldn't smell any either. Is this 'RATTLING" anything to be concerned about? What would cause this kind of fuel consumption?

[snapback]742662[/snapback]​
I wonder if the dealer
adjusting my oil cable had anything to do with it?
[snapback]742856[/snapback]​
If you're running a Dynoport can get rid of it. I've had 2 go bad this year 500 miles
you may have a stuck injector as for the rattling and or exceesive fuel guzzling
You could try disconnecting 1 injector at a time to try and isolate it
[snapback]743332[/snapback]​
What can did you go with? Are the MBRP cans any good?
 

·
Registered
Joined
·
588 Posts
Discussion Starter · #18 ·
I have confirmed I have a SMALL gas tank. I didn't like it that way so I enlarged it by letting the sun hit it and pop out the DENT! Not sure how it got there but I shouldn't be needing the gas can any time soon. It was a 2 to 3 gallon size dent!
 

·
Registered
Joined
·
111 Posts
Boondocker-1 said:
bbob said:
Did they put the new fuel pump in it for the updates?
[snapback]747193[/snapback]​
They claim they did. How can I know for sure? Any way to tell?
[snapback]747213[/snapback]​
Look under the motor right under the recoil. You will see a black electric fuel pump bolted to the bottom of the bulkhead. This is probably the knocking you heard under the motor. If you push the start button you should hear the knocking sound of the new pump. You will hear this until it pressurizes the system, or while idling the pump will continue to run.

...MAX
 
1 - 20 of 20 Posts
Top