Ski-Doo Snowmobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
While on my trip to the UP this weekend I started having troubles with my 800X after it warmed up. As long as I kept it above 6000rpm's it would run fine. I can hear it missing while it is running. While going down the trail it would shut everything down, backfire then run again. It would also backfire EVERY time that I shut it down. I also used at least 2 times what my wife used in her 04' Renegade!!

Do you think that I could have sucked a ring in?

Thanks for the HELP!!

 

·
Registered
Joined
·
17 Posts
Discussion Starter · #2 ·
ttt
revriders said:
While on my trip to the UP this weekend I started having troubles with my 800X after it warmed up. As long as I kept it above 6000rpm's it would run fine. I can hear it missing while it is running. While going down the trail it would shut everything down, backfire then run again. It would also backfire EVERY time that I shut it down. I also used at least 2 times what my wife used in her 04' Renegade!!

Do you think that I could have sucked a ring in?

Thanks for the HELP!!


[snapback]712025[/snapback]​
 

·
Registered
Joined
·
120 Posts
One thing to check is spark plug caps. If the tops of your plugs are black with soot deposits, might be your caps have lost their tension. NGK makes a good replacement. Just a reminder, while checking for spark always have a spark plug in the cap. Good Luck
 

·
Registered
Joined
·
106 Posts
That does not sound like a ring problem to me.

Until you said that it was using way too much gas I would have said that it sounds like you stator is on its way out, which could still be the case. I would first check to see if it is flooded out. I would check to see if you have gas in the exhaust and I would pull the plugs and pull the machine over with the kill switch off (you don't want any spark) to see if fuel sprays up out.

I have had the diaphrams in the fuel pump stick on me, and it will allow the bottom end to fill up and the machine will run like crap unless you are really getting after it. Was it hard to start?
 
1 - 4 of 4 Posts
Top