Ski-Doo Snowmobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited by Moderator)
Hi Folks,

I have a 2002 Legend 500 fan that loses power after riding longer distances (meaning not around the yard or on slower trails) where throttled up for longer periods of time OR when going across lakes. Runs fine cold and short distances where its not pushed as hard. Cleaned the carbs (personally and by a mechanic), replaced the coil as well. Running 91 octane non-ethanol fuel. Any idea what could be the issue? I've read vacuum hoses that leak when hot (checked and they are fine), clean/tweak the clutches, and crank seal, but haven't dared to dive into those without learning more. Thoughts? Thanks in advance.

I should also note that the sleds have 1300 and 1500 miles on them, respectively and I've owned them both on and off - never ridden super hard. But the Legend did sit for 5 years or so with no one riding it.

PS - Ironically, my 1997 500 Grand Touring 2-up (liquid) just started doing the same thing after harder riding
 

·
Registered
Joined
·
25 Posts
Check the line inside the tank. Should have a weighted filter on the end of the line. Could be clogged,preventing enough fuel to get to the carbs
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks slimmer455 - I replaced it 2 years ago - but good chance it is clogged again - will check it out!
 

·
Registered
Joined
·
518 Posts
Are both sleds fuelled up from the same source?

Drain and refill fuel system. (Tank, carbs, lines, pump everything).
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Cold compression is 125 per cylinder, what is the norm for these? Will do a hot test tomorrow after riding a bit.
 

·
Registered
Joined
·
518 Posts
Crank seal (PTO) side, spray a "BIT" of ether between the clutch and case and see if the RPM picks up.

Heat related drivability can also be an electrical issue. Coil, plug wire, magneto etc.

125 is pretty good. How many KM or miles on it?
 

·
Registered
Joined
·
25 Posts
Replace the spark plugs. I know, plugs with low milage shouldn't fail, but i had a bad one this year. Bogging problem solved after I tried everything else.
 
1 - 9 of 9 Posts
Top