Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello Everyone,

I am looking for some advice/assistance - please. I have a '98 Z -LTR and trying to get the clutching right. I mostly trail ride but occasionally play in the powder (why i bought the LT) my current setup is:
286 ramps
200-320 primary
secondary @ 16 lbs with a 53/47 helix
stock weight on primary arms
26/43 gearing
new belt - 200km ago
stock track (0.9") - no studs

What I am experiencing is what must be belt slippage on the primary - belt deposit on primary. Machine seems to pull ok - but this sled is new to me and i came of a 1996 FIII 600 - on the hard pack speedo goes to 100mph quickly then falls off - haven't been able to exceed 105mph. Would like to eliminate belt slippage and bring top end around 115-120 without sacrificing to much bottom end (still want to play in powder sometimes)! - Any suggestions

Thanks for any assistance you can provide!
 

Attachments

·
Registered
Joined
·
104 Posts
try 18-20lbs on secondary you are shifting out to fast by adding lbs this will hold your shift longer hope this helps digger!!!!!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
1fastmach said:
TO MUCH HELIX....TRY THE 50-47 OR 48-44..THIS WILL KEEP YOUR RPMS HIGHER AND THE SLED WILL PULL HARDER........GARY
[snapback]732217[/snapback]​
Thanks - any recommendations on primary spring - some of my friends siad i should try something with at least a 350-380 finish - i was thinking of trying a 200-380!

 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top