Ski-Doo Snowmobiles Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
HELP ME PLEASE, My 15 y.o. brother just bought a 94 Ski-Doo Mach Z 780 about 4 weeks ago, The sled had been sitting for about 2 years. So I drained the fuel, Cleaned the carbs (being carefull to install everything back in the correct carberator), Fuel tank, And replaced the (BR9ES) plugs, And tested it out around the house............ HOLLY FAST. I decided to take it out on the lake, I was putting around when a few guys came over to me riding a 19?? Yamaha 700 Mountain Max, 199? Polaris 700 RMK, and a 94-95 Polaris 900 ???, They had been racing up and down the lake for about 30 min. Figuring (Im sure) I was riding a weak/slow sled they asked me if I wanted to race, I knew I was going to get my butt kicked but I figured what do I have to loose. So there we were all lined
up.......3.......2.......1..........GO Yells the guy on the Polaris 700. And off we go, The 900 got the hole shot, But my brothers Ski-Doo that I had pegged for a loss not only cought up and FAST but completely SMOKED that 900. I could not believe it. Ok lets see I got a little off track here. After riding his sled for 200-250 miles it scored the sides and pitted the top of the pistons. So I took the jugs, head, and pistons to Kurt's Polaris here in Seeley Lake, Mt. We got luckey and didnt have to bore the cylinders (Just honed them out). We also purchased a Weisco pistons and a top end gasket kit. $438.75 later, My father and I had it going again.

Unsure of how this happened we came to the conclusion that it had to be the oil pump not putting out enough oil (seeing as how we went through 2/3 of a tank of fuel and less then an 1/8 th tank of oil).............So we mixed the oil and fuel in the tank (50:1) (Untill we could have the oil pump looked at). Once again my brother was off and running. Figuring we needed to break in the piston rings, We told him to go easy on it for the first tank of fuel. Knowing how my brother is I went with him using my other brothers sled (Polaris Indy 700 (I cannot stand this JUNK SLED)) to make sure he didnt try racing anyone. About 4 hours of putting around 30-35 mph on Seeley Lake, he pulled up to me and asked if he could get into the throttle a little bit, Just to see what it had. I couldnt resist (Even though I knew he was going to beat me) I told him we would do one 1/4 mile race. Just before he crossed the finish the sled started to bogg down and slowley came to a dead stop and then just died out. So my brother pulled it over a few time and it started up. After it started it sounded like it had a fouled spark plug so we headed back home to replace the plugs. So my father and I headed outside to check the plugs. I just about had a heart attack. To our amazment there was a hole the size of a dime in the BRAND NEW $295.(clutch side) piston, The center and the mag side were both scored and had pitting on the top of the pistons.

So we took the sled to Kurt's Polaris here in Seeley Lake. There mechanic came out and looked at the sled and told us that the factory air box had been removed and air sock type air filters had been installed along with an exhaust "silancer"had also been installed. So he said the sled was getting too much air and in turn making it run lean.

This sled has factory jets (mag side jet is a 360, center is a 350, And the clutch side is a 350) Our elevation here in seeley Lake is 3,700 ft.

My brother is running out of money and needs to make this next fix the last one for a while. He has had a taste of this machines power and became INSTANTLY addicted. we still have atleast 2 more months of snow left this winter and he is going crazy trying to get this sled repaired before summer.

So here is my problem/Question:

1.)Is it just a mixture problem? if so what size jets do i put in it?
2.)Does anyone have a factory air box and how much?
3.)What are the best pistons I can get for this sled?
4.)I have been told that your not supposed to hold any sled at full throttle (WOT), Is this true?
5.)Where can I get parts for this sled?

Thanks to anyone that can give any insight into this problem. It is greatly apreciated.

Richard J P Jr...
 

·
Registered
Joined
·
41 Posts
Old sleds sometimes mean bad crank seals. Worth a look. Mixing the gas and oil is NEVER a good idea. It's an old wives tale. Oil burns so hot that you end up with temps that appear as a lean condition when it's actually not. A tank of oil on that sled should last near 300 miles. You might have been just fine there. Wiescos need to be warmed up when starting cold. They are notorious for cold seizing but that's probably not what happened. Just some info to remember. As far as holding WFO, for a 1/4 mile shoulda been OK, but for a lean race tune up, no. Where are the carbs vented? Doo had them vented to the airbox for a long time, but I don't know if they did that in 94. Vented to the box they read the same pressures as the incoming air. A discussion that could go for hours. Maybe some others will chime in.
 
1 - 2 of 2 Posts
Top