Ski-Doo Snowmobiles Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
So I have a 1980 citation ss motor in a 4500 with cdi ignition swap. I am looking at rebuilding my carbs.
When I start the sled it seems to be getting fuel through one carb. Ones it struggles to run for 2 minutes it begins to run smooth.
I am wondering what you guys are running for jetting and what stock was.

Also, do you think this could be a fuel pump issue? I have a couple spares I could try.
 

·
Registered
Joined
·
4,108 Posts
150 was stock.Can you identify which cylinder comes on late ? Dont think your fuel pump is wrong and your main jet is not the problem.Clean carbs,be sure pilot jets is CLEAN. When you say after two minutes,it runs smooht,thats at idle ,right ?
 

·
Registered
Joined
·
2,249 Posts
sync your carbs first make sure the problem cylinder is not a little flooded check the spark plug cap to make sure it is making a good connection yes like HiOctane said CLEAN do you have injection or are you premixing? how are the crank seals?
 

·
Registered
Joined
·
2,249 Posts
So I have a 1980 citation ss motor in a 4500 with cdi ignition swap. I am looking at rebuilding my carbs.
When I start the sled it seems to be getting fuel through one carb. Ones it struggles to run for 2 minutes it begins to run smooth.
I am wondering what you guys are running for jetting and what stock was.

Also, do you think this could be a fuel pump issue? I have a couple spares I could try.
if it was fuel pump it would flood both sides or affect both sides your carb set up should be 2 x VM30-111 Carbs
main jet 150, needle 6DH7-3, needle jet 159p-0, pilot jet 40
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
Thanks guys, I will check these things out this weekend.
The chank seals are pretty good. Not perfect, I was thinking that a slight leak until work might be causing issue.
I didn't think it would be fuel pump.
It starts to run smooth on idle after two minutes, It needs help before that point with some playing with the throttle and the odd little squirt from primer.
 

·
Registered
Joined
·
2,249 Posts
Thanks guys, I will check these things out this weekend.
The chank seals are pretty good. Not perfect, I was thinking that a slight leak until work might be causing issue.
I didn't think it would be fuel pump.
It starts to run smooth on idle after two minutes, It needs help before that point with some playing with the throttle and the odd little squirt from primer.
ok that being said i'm not great with just a slight leak with crank seals BUT synchronize the carbs and clean the carbs and check compression
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #8 ·
I don't think there is a slight leak in the crank seal. I was saying that if there were, could that be the culprit.
Compression is just shy of 110 per side I believe.
 

·
Registered
Joined
·
539 Posts
Mine does something similar,I've never thought to time how long it acts that way but it isn't very long 1 minute or less I would guess. I just chalk it up to "warm up". I don't really have to feather the throttle,just keep a hand on the primer for the odd well timed "squirt". After it warms up on idle it will sit there all day "purring",runs like a scalded cat all day long. <110psi is getting down a bit.Give the crank seals a quick check with a bit of starter fluid to rule those out.

Love those SS's :ninja:

Steve
 

·
Registered
Joined
·
2,249 Posts
yes just like daastevoe said when you get to 110 psi you will start having starting issues and running issues if it's only 110 psi you most likely just have to replace rings
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #12 ·
How do I check the crank seals ?
After it runs a bit to warm up, it I'll idle all day long and runs like snot too.
 

·
Registered
Joined
·
2,249 Posts
How do I check the crank seals ?
After it runs a bit to warm up, it I'll idle all day long and runs like snot too.
ok if a motor is cold that's when you see problems for leaks lets say, seals if leaking especially the one that controls the pulse will alter performance
by reading all the posts it just sounds like a motor with a lot of miles on it and it needs a good rebuild if it runs great after a warm up your good to go but keep in mind you probably near a rebuild drive it until it stops LOL!
 
1 - 14 of 14 Posts
Top