Ski-Doo Snowmobiles Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Hi Guys

Looking for a little help .... Anyone else having issues with their Cardo Pactalk and the 10.25 gauge communicating? ..

I have my phone and sled paired to my Cardo, however, I cannot hear music or use voice commands while its connected to my sled. I can see the music on the display but with no sound, and it's the same with navigation. 4 of us with new sleds and the 10.25 all had the same issue with our Cardo's .

If I disconnect my BRP connection from the sled everything works like a normal communicator, but then I lose all of the handlebar functionality through the communicator....

Just curious if anyone else has had this issue and found a cause or solution.

Regards SPF
 

· Registered
Joined
·
1,732 Posts
Hi Guys

Looking for a little help .... Anyone else having issues with their Cardo Pactalk and the 10.25 gauge communicating? ..

I have my phone and sled paired to my Cardo, however, I cannot hear music or use voice commands while its connected to my sled. I can see the music on the display but with no sound, and it's the same with navigation. 4 of us with new sleds and the 10.25 all had the same issue with our Cardo's .

If I disconnect my BRP connection from the sled everything works like a normal communicator, but then I lose all of the handlebar functionality through the communicator....

Just curious if anyone else has had this issue and found a cause or solution.

Regards SPF
Our group has constant problems with cardo. Always disconnecting and batteries dying.

Before rides we normally set it all up on hotel room. Pia as we are always re-linking the sets to each other.

Sent from my Pixel 3 XL using Tapatalk
 

· Registered
Joined
·
188 Posts
I don't have cardo but with Sena you need to pair the phone and the communicator to the sled but not each other. If your phone and communicator are paired to each other, delete that connection so it doesn't compete for volume control via the sled.
 

· Registered
Joined
·
35 Posts
Discussion Starter · #4 ·
I would go along with that, however, the Cardo tutorial on you-tube (Pac-talk edge) instructs you to link your phone 1st, and then to the vehicle 2nd. Cardo has a slightly different pairing procedure
for the sled/vehicle/bike as well.

I would agree the 2 connections seem to be fighting each other, but this is the latest and greatest Cardo that was designed to connect 2 BT sources ... I'm saying that with a smile, isn't technology great : )

I will give it a try regardless, can't hurt, and I'll report on any positive outcomes.. Thanks for the help ..
 

· Registered
2022 Enduro 900 T130
Joined
·
164 Posts
I don't have cardo but with Sena you need to pair the phone and the communicator to the sled but not each other. If your phone and communicator are paired to each other, delete that connection so it doesn't compete for volume control via the sled.
I am going to have to try your suggestion it makes perfect sense. Wife and I did not use the BRP Go app or connect our phones to sleds other than to charge them at all last year. This year we started trying it for the distance to destination. We know the trails where we ride so did not think much about using it last year. That being said currently I have the phone connected to the communicator via Bluetooth. I knew it definitely has to do with the way I have them connected to each other I just didn't care to mess with it and get frustrated so I just disconnected from the sled. In order to listen to Spotify I would have to disconnect from BRP Go Bluetooth to get the music in my UClear Infinity. I will give this a try next week when I get back to my sleds.
 

· Registered
23 Renegade XRS, 72 Polaris Charger 530
Joined
·
1 Posts
I have a Pactalk Bold and have it working with the 10.25 gauge. i have the Cardo connected to the gauge only and phone connected to gauge only. Bluetooth between the phone and Cardo is turned off. I’m able to speak to others in the group and control music from the screen and handlebar controls. Can make/receive calls as well (which is interesting as you’re blasting down the trail). I haven’t tried the voice commands but haven’t needed to either.
Joe
 

· Ski-Doo Guru
Joined
·
13,903 Posts
It does not work correctly. I have the syphon BT headset. If I pair my phone to the sled with BT and my headset to the sled I get no sound. I have to connect the headset to my phone only to get sound. I can control the music / volume with my phone plugged into the sled but if I BT to the sled I loose sound. Without the BT connection BRP go doesn’t work.
 

· Registered
Joined
·
48 Posts
Great info here. I am having the same issue with a Sena 50S. I will delete the connection between the phone and Sena and see if that fixes it. BRP does say to connect the phone to the sled first then connect the communicator to the sled. They do not mention anything between the phone and communicator.
 

· Registered
Joined
·
370 Posts
it's NOT the cardo it's the 10.25... when I had my Polaris 7s my cardo always worked.. its constantly disconnects the cardo from the gauge and I cant reconnect unless i reboot the screen. BRP has lots of work to do on the screen. I would but the 7s again, I would NOT buy the 10.25 in its current form
 

· Wasting money wisely
Joined
·
1,618 Posts
There needs to be an update from Doo. Everything works great until I use the handlebar controls. Some Bluetooth devices work fine and some need to be disconnected and connected again to hear anything. I just don’t use the handlebar controls, for now.
 

· Registered
Joined
·
35 Posts
Discussion Starter · #13 ·
I've tried all of the suggestions above regarding the pactalk edge, and also experimented with a few different pairing sequences and I've still had no luck with sound . I'll revert to pairing my cardo and phone together, and forget the sled paring. Certainly would be nice to have that functionality so hopefully, there's a fix for this at some point.

SPF
 

· Registered
Joined
·
4 Posts
I am having the same issue. Everything works. But I cannot hear the music. I have the Cardo Edge and the 10.25". I can make a call, receive a call, talk and use the handle bar controls. When it comes to the Media end, I cannot hear the music, but the handle bar functions all work. I can see the music playing, I can pause, forward, raise and lower volume, but I cannot hear anything.
 

· Registered
Joined
·
98 Posts
I rode for the first time this weekend and spent a lot of time trying to get my brand-new Syphon Sound system to work with the new fancy "Expensive" 10.25"BRP Gauge. VERY DISSAPOINTED once again with BRP. I think they need to hire whoever is working for Polaris Tech Dept because everything lately that they come out with has major issues. I can connect both the phone and Syphon Sound to the sled via Bluetooth. Everything shows connected and media songs even show up via the gauge. NO SOUND!! I ended up giving up and just paired to the phone for music but with doing that I am not able to run my BRP GO app and maps. So basically, no better than last year's gauge in my opinion. With such a short-lived season, you would think they would do a bit more R&D to get these bugs worked out so when it comes time to actually ride the features that the customer spends big $$ on can actually be used. I contacted Syphon Sound directly to make sure it wasn't a known issue with something on their end. Like always I got a response from the Customer Service Department almost instantly (Hats off to them with Awesome support of their product) The response stated to Bluetooth the phone to the sled and then connect your phone to the SoundPro, then in the phone under Bluetooth settings, turn off calls/media permissions and that allows everything to work in the screen other than the volume control. For whatever reason, that still needs to be controlled by the SoundPro controller. (BRP Issue because all other devices that the SoundPro has connected to the volume can be controlled by the SoundPro and by the connected device) I sure hope that BRP looks at these forms and notes all the issues and maybe can respond and provide some very needed information soon. I will also notify them of the issue but doubt anything will be done or responded to.
 

· Registered
Joined
·
4 Posts
i heard there is an online update coming from BRP for this. Another cool feature of this gauge
I rode for the first time this weekend and spent a lot of time trying to get my brand-new Syphon Sound system to work with the new fancy "Expensive" 10.25"BRP Gauge. VERY DISSAPOINTED once again with BRP. I think they need to hire whoever is working for Polaris Tech Dept because everything lately that they come out with has major issues. I can connect both the phone and Syphon Sound to the sled via Bluetooth. Everything shows connected and media songs even show up via the gauge. NO SOUND!! I ended up giving up and just paired to the phone for music but with doing that I am not able to run my BRP GO app and maps. So basically, no better than last year's gauge in my opinion. With such a short-lived season, you would think they would do a bit more R&D to get these bugs worked out so when it comes time to actually ride the features that the customer spends big $$ on can actually be used. I contacted Syphon Sound directly to make sure it wasn't a known issue with something on their end. Like always I got a response from the Customer Service Department almost instantly (Hats off to them with Awesome support of their product) The response stated to Bluetooth the phone to the sled and then connect your phone to the SoundPro, then in the phone under Bluetooth settings, turn off calls/media permissions and that allows everything to work in the screen other than the volume control. For whatever reason, that still needs to be controlled by the SoundPro controller. (BRP Issue because all other devices that the SoundPro has connected to the volume can be controlled by the SoundPro and by the connected device) I sure hope that BRP looks at these forms and notes all the issues and maybe can respond and provide some very needed information soon. I will also notify them of the issue but doubt anything will be done or responded to.
Goto the 2:10 on this skidoo video. It’s the only place I have found this mentioned anywhere.
 
1 - 17 of 17 Posts
Top