Ski-Doo Snowmobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
While worring about my 16 Blizzard getting Hot by putting snow on rear heat exchanger, turned them off etc.. just trying to get through this poor section of town the 06 SDI stared beeping. My son immediately turned it off but I have never herd it do that since new. Sled seems fine yet but I was wondering if the temp light came on first and he just didn't see it and then the beeping? Just wondering or did I do more damage than I realize?
 

·
Registered
Joined
·
2,561 Posts
Should be fine, just check antifreeze
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #5 ·
Sled ran fine today. Just a little concerned since I still love this sled. Over 8000 miles on it and still very strong! We were on our way back home and the sled didn't beep till we were in our yard while he was waiting for me to get the garage door open and get my sled in. He should have turned it off sooner but normally that sled never runs hot. We didn't have snow along the road to pic up. I had snow on my rear exchanger and he didn't because of the luggage bag. I just wish I knew if the warning light went on first.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #7 ·
My Blizzard had the temp gauge on and was at 162. I have been putting off getting a temp gauge for the Rev since new. Usually somebody else has a temp gauge with the same chassis. Well everyone is updating and now it's the only one left. I'll have to suck it up and get one. For the record....this sled isn't that far off from my new Blizzard. I need to spend more time going back and forth yet. Seating position is the biggest improvement tho.
 

·
Registered
Joined
·
249 Posts
I'll answer the question that no one else did..
No your temp light did not turn on before it started beeping. Too make the beep stop when you hit the kill switch,just take the key off
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #10 ·
Yeah it still beeped when the sled was off. Odd I thought. This has been a poor year for snow in Wisconsin and especially where I ride. A guy gave a post about all the warning signs an etech will go through at different levels of temps. I wish 162 was the lowest I saw that day.... I shut it down at 175 and wait to cool off.
 
1 - 10 of 10 Posts
Top