Ski-Doo Snowmobiles Forum banner
1 - 20 of 43 Posts

·
Registered
Joined
·
1,471 Posts
Discussion Starter · #1 ·
anybody else having this happen as your about to accelerate from a stand still? the sled will bog , sometimes so bad that it feels like u hit the brakes we have 5 of these sleds and their all doing it? what is the cause? and how to get rid of?
 

·
Registered
Joined
·
162 Posts
I'm having the same problems! any help here would be greatly appreciated. it falls right on it's face. seems like its in the pilot circuit of the carbs.
 

·
Registered
Joined
·
775 Posts
real7362 said:
I'm having the same problems! any help here would be greatly appreciated. it falls right on it's face. seems like its in the pilot circuit of the carbs.
[snapback]270042[/snapback]​
Change the pilots to #20 I think the stock was 17
 

·
Registered
Joined
·
205 Posts
Are your carb heaters on? They will cause that when they are on but not needed. I am still trying to figure out exactly when they are needed and when not. If yours were all on then try a couple with them turned off and see what happens.

 

·
Registered
Joined
·
1,259 Posts
Mine also does it but so did my Gade last year mine only does it when cold. I did change to 20 pilots this week end but can't try it till it stops snowing(Blizzard). I will try it this week and let you know
 

·
Registered
Joined
·
417 Posts
Sure the mileage will be affected, replacing 17.5 pilots with 20's will give the motor more fuel at the same throttle position . More fuel means less mileage, how much less ? well you will be the one to find that out. Won't be that much and you can always change it back. I put the 20,s in my 05 as it just seemed to lean down low. I know it's new and has DPM with the warranties, but I can hear a lean condition when letting off, and feel safer giving it some more fuel for cooling when it needs it. The P-tek motors are 06 compliant and to get there they are not giving it any more fuel than absolutely necessary It idles somewhat richer without adjusting the mixture screws but not enough to worry about , and that's what I was looking for in the first place.
 

·
Registered
Joined
·
1,471 Posts
Discussion Starter · #12 ·
440man said:
Your encountering a LEAN spot. Put the #20 pilot in it and your problems will be solved...
[snapback]270292[/snapback]​
it almost seems the opposite of a lean spot , too much fuel dumped in all at once , if u feather the throttle it does not do it at all it only happens if u mash the throttle all the way quickly!! drag racing situations.
 

·
Registered
Joined
·
302 Posts
So there is #17.5 pilots stock in the PT, and you guys recommend #20...
Do you know what size main jets is stock in the 800 PT???
 

·
Crazy Person
Joined
·
5,615 Posts
Mine used to do that during break-in and after that it stopped. 5000 km's and she accelerates from 0 to 100 MPH like a rocket! I don't understand why mine stopped and most of you are having a problem...what the mileage on your engines?
 
1 - 20 of 43 Posts
Top