Ski-Doo Snowmobiles Forum banner
1 - 15 of 15 Posts

·
Clowns to the left of me, jokers to the right.....
Joined
·
1,570 Posts
I've been riding this POS for 700 miles and haven't had to replace 1 spark plug. The blasted thing sucks all of about 38 liters out of the tank. And the worst thing is it shows WAY over 120 on the speedo.

I went out and bought a couple boxes of plugs and planned to stop way less than 100 miles for gas and it just isn't turning out that way.

And to really get myself worked up, the thing doesn't chew up sliders.

I'm really kind of disappointed that I can't join in with all the complainig the girls have going on here.

Here's the junker along with an 800X that doesn't go with the program either, original rings at 2200 miles.............
 

Attachments

·
Registered
Joined
·
183 Posts
SuperCharged said:
I've been riding this POS for 700 miles and haven't had to replace 1 spark plug. The blasted thing sucks all of about 38 liters out of the tank. And the worst thing is it shows WAY over 120 on the speedo.

I went out and bought a couple boxes of plugs and planned to stop way less than 100 miles for gas and it just isn't turning out that way.

And to really get myself worked up, the thing doesn't chew up sliders.

I'm really kind of disappointed that I can't join in with all the complainig the girls have going on here.

Here's the junker along with an 800X that doesn't go with the program either, original rings at 2200 miles.............
[snapback]310820[/snapback]​
you have way too much time on your hands!
 

·
Registered
Joined
·
3,395 Posts
SuperCharged said:
I've been riding this POS for 700 miles and haven't had to replace 1 spark plug. The blasted thing sucks all of about 38 liters out of the tank. And the worst thing is it shows WAY over 120 on the speedo.

I went out and bought a couple boxes of plugs and planned to stop way less than 100 miles for gas and it just isn't turning out that way.

And to really get myself worked up, the thing doesn't chew up sliders.

I'm really kind of disappointed that I can't join in with all the complainig the girls have going on here.

Here's the junker along with an 800X that doesn't go with the program either, original rings at 2200 miles.............
[snapback]310820[/snapback]​
Hey buddy it is great your sleds are working out for you. BUT if no one says anything about problem sleds nothing will get done about it. What is a warranty for??? I would like to be able to not run out of fuel with 4 gallons left in the tank. The plug fouling seems to be gone BUT I have not seen a BR8ECS as of today at my dealers-back order from BRP. Bulletin came out 3 weeks ago and no parts for the bulletin. Your riding season may be long but ours is 12 weeks tops-the lack of spare parts and wear parts is not acceptable-BRP cannot start making the parts as the orders come in-that is what they are doing now and they suck. BTW the shocks that came on the sled suck also-you forgot about that one.
 

·
Registered
Joined
·
136 Posts
SuperCharged said:
I've been riding this POS for 700 miles and haven't had to replace 1 spark plug. The blasted thing sucks all of about 38 liters out of the tank. And the worst thing is it shows WAY over 120 on the speedo.

I went out and bought a couple boxes of plugs and planned to stop way less than 100 miles for gas and it just isn't turning out that way.

And to really get myself worked up, the thing doesn't chew up sliders.

I'm really kind of disappointed that I can't join in with all the complainig the girls have going on here.

Here's the junker along with an 800X that doesn't go with the program either, original rings at 2200 miles.............
[snapback]310820[/snapback]​
I thought I was the only one who liked their Mach!
 

·
Registered
Joined
·
211 Posts
BackinBlack said:
SuperCharged said:
I've been riding this POS for 700 miles and haven't had to replace 1 spark plug. The blasted thing sucks all of about 38 liters out of the tank. And the worst thing is it shows WAY over 120 on the speedo.

I went out and bought a couple boxes of plugs and planned to stop way less than 100 miles for gas and it just isn't turning out that way.

And to really get myself worked up, the thing doesn't chew up sliders.

I'm really kind of disappointed that I can't join in with all the complainig the girls have going on here.

Here's the junker along with an 800X that doesn't go with the program either, original rings at 2200 miles.............
[snapback]310820[/snapback]​
I thought I was the only one who liked their Mach!

[snapback]310990[/snapback]​
I also have no plug fouling or fueling issues, but my dealer sold 4 machs and mine is the only one to not use plugs, by the way still running that rotten skidoo synthetic oil. i'm feeling lucky.
kuds1
 

·
Registered
Joined
·
8 Posts
The only complaint I have on my '05 Mach Z is the hole in the toe of my right boot.
Its wearing on the bracket for the battery mount for the SDI. Is any one else having this problem? If so they covered mine under warrenty and said there were only 3 complaints and they just so happened to be in my area. I'd like to see bombardier acknowledge the problem and come up with a fix. It doesn,t make sense to replace my boots if their not going to fix the problem. I guess I'll have to come up with a soloution. The only plugs I have fouled were at 20 miles and 52 degrees farenheit. I regapped the replacements at 31 and haven't had a problem since. Other than that I love my Mach.
 

·
Registered
Joined
·
877 Posts
machalam said:
I'd like to see bombardier acknowledge the problem and come up with a fix. It doesn,t make sense to replace my boots if their not going to fix the problem. I guess I'll have to come up with a soloution.
[snapback]311467[/snapback]​
They gave you boots because they actually have those on the shelf and it didn't cost a penny in tech time. Any actual real fix won't happen with BRP. Remember, this is no longer Bombardier.
 

·
Registered
Joined
·
1,388 Posts
Supercharged you should touch wood. Now go out & put 800 more miles on your sled in cold weather without topping it up all the time. If all remains the same save that piece of wood. Now try 1000 more miles & let us know. As for your 800 are you saying your compression is over 145 psi & it's as fast as when you first got it?
If so, can you suggest some lottery numbers for me to try because I own the same sleds as well as a 600 SDI & all have issues. Mach 2500 miles.
800x 5000 miles.
600 4100 miles.
 

·
Clowns to the left of me, jokers to the right.....
Joined
·
1,570 Posts
Discussion Starter · #11 ·
Black Toys said:
Supercharged you should touch wood. Now go out & put 800 more miles on your sled in cold weather without topping it up all the time. If all remains the same save that piece of wood. Now try 1000 more miles & let us know. As for your 800 are you saying your compression is over 145 psi & it's as fast as when you first got it?
If so, can you suggest some lottery numbers for me to try because I own the same sleds as well as a 600 SDI & all have issues. Mach 2500 miles.
800x 5000 miles.
600 4100 miles.
[snapback]311794[/snapback]​
I guess the jist of your post is that I CAN'T have two good running sleds that I am completely satisfied with.

SC
 

·
Registered
Joined
·
245 Posts
Well I think I have mine all better now I am glad your sled runs just fine for you save you a ton of time I wish mine came this way but with the help from all the GUYS on here I think I have it all good I would like to thank All you guys tinkering and testing on here!!! I work 12 on 2 off and save vacation for trips I think my trip coming up will be a good one
 

·
Registered
Joined
·
3,395 Posts
SuperCharged said:
Black Toys said:
Supercharged you should touch wood. Now go out & put 800 more miles on your sled in cold weather without topping it up all the time. If all remains the same save that piece of wood. Now try 1000 more miles & let us know. As for your 800 are you saying your compression is over 145 psi & it's as fast as when you first got it?
If so, can you suggest some lottery numbers for me to try because I own the same sleds as well as a 600 SDI & all have issues. Mach 2500 miles.
800x 5000 miles.
600 4100 miles.
[snapback]311794[/snapback]​
I really don't care about your experiences, all I can relate to you is MY experience. If you don't believe me, that's tough. Actually the 800 is a little faster than it was the first time I maxed it out. Not all sleds are problems, though by the sounds of the girls on here, you would think so.

[snapback]311928[/snapback]​
So we are supposed to believe the hype, fork out $10,000+ usd, wait, wait some more, and wait just a little longer, pick up the sled, and begin doing the r&d for BRP??? Good thing the motor runs ok most of the time-I bet they have zero pistons in stock. BRP to dealer and customer "sorry we did not make any spare parts for the Mach Z's-we made them so good you won't need any"
 

·
Registered
Joined
·
1,388 Posts
Supercharged, I'm just jealous but at the same time am giving you a heads up because my oil related plug problem started after 1300 miles. Fouled plugs only once at start-up during early breakin & all I had with me were some old worn out br9es @ .018. They lasted 700 miles before age caught up. I left them in that long because it ran better & also there were no stock plugs available. My riding problems only happened @ -20c or colder with 1/3 of a tank or less. Rapid squeezing of the throttle would refire motor while I was still coasting. Luckily I was always on a fairly straight trail because sometimes when it refired skis ended up tractionless. Have hit a tree before so this issue is unacceptable. Just imagine it happening on a corner amongst trees in cold weather with excellent traction. Sometimes complaints may just prevent a serious mishap. Good luck with yours.
 

·
Ski-Doo Guru
Joined
·
13,820 Posts
2000 Miles here no plugs fouled nothing. Uses all the gas in the tank, 1 lite to a tank of fuel of oil. Clutch kit and plugs done thats it. Hauls the mail, complaint though had to put 03 REV x suspension on it to make it rideable at the speed I travel in the trails. Other then that best sled I have owned.
 
1 - 15 of 15 Posts
Top