Ski-Doo Snowmobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
826 Posts
Discussion Starter · #1 ·
Yesterday we were out riding, doing some powder riding and trails. Later in the day, Sled would not pull past 7400 rpm.

Hit 8k from a stop, but when moving would not pull 8k. Stopped for dinner, let her cool off figuring it was the belt slipping from powder riding or heat. Rode it, same thing, 7400. Changed the belt to a new one, ran it for a few miles, same thing, 7400. Few miles later, tested it, it was back to normal.

Buddys 800 rev ran out of gas, so we were going to tow it and I switched the belt back to the old one (750 miles on it), and it was back to norm, hit 8k and pulled like mad..

Ran it today with old belt, no problem. We dragged, and 5 of 5 I am even out of the hole with the 03 800, then he gets a half a sled in mid, then I pull away at 80 or so......

Not too shabby for a lil 600!!!

Why would I have seen this loss of rpms??

And then back to norm??
KK
 

·
Registered
Joined
·
826 Posts
Discussion Starter · #2 ·
Anyone?
 

·
Registered
Joined
·
464 Posts
Mine did the same thing earlier this year in the UP. Only hit 7000 though. I just kept riding and it went back up to 8k. I attributed it to belt slippage. I have the same belt on at 1600 miles. Changed secondary to #4.
 

·
Registered
Joined
·
826 Posts
Discussion Starter · #4 ·
Fatboy said:
Mine did the same thing earlier this year in the UP. Only hit 7000 though. I just kept riding and it went back up to 8k. I attributed it to belt slippage. I have the same belt on at 1600 miles. Changed secondary to #4.
[snapback]292120[/snapback]​
Mine is on 4 from the dealer...is that right?
 

·
Registered
Joined
·
826 Posts
Discussion Starter · #6 ·
rottinjonny said:
Sounds like the primary spring is hanging up ? J.T.
[snapback]292940[/snapback]​
Hmmmm, sounds like something to watch. how do you know that it i the spring though....a way to check it?

KK
 

·
Registered
Joined
·
1,151 Posts
Had this happen on my 04' gade. You will have to take it out and check.
The spring may be weak and/or bound up in the plastic primary spring cover.
J.T.
 

·
Registered
Joined
·
5,793 Posts
Check your RAVE's. mine did exactely this when it blew the bellows apart. Its simple and easy, just check when it happens.
 
1 - 9 of 9 Posts
Top