Ski-Doo Snowmobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Ok, my saga continues.

Just got my sled back. New short block, installed cudney rings and his billet head.
New carb boots were installed as well.

The idle hangs when you get out of her. This is a sign of lean right? I have to burp the choke to get the idle to come down. Hangs around 4 grand. Does not creep back up though after you burp the choke, stays down at a good idle. Got about 80 miles on the engine, and the tank was oil mixed. Running ski-doo synthetic blend. Tank has got mostly 93 octane in it now.

Does this sound like a lean condition?? Does the head have anything to do with this?? Was supposed to go riding today but I opted out until I can get an idea if I am hurting the engine and I can get it to my dealer.

Any thoughs would be great, cause I am beyond frustrated with this.

Thanks.!!
 

·
Registered
Joined
·
895 Posts
clean carbs....check jets ..

double check for leaks on carb boots

call bill.... his head his rings should be able to point you in the right direction
 

·
Registered
Joined
·
682 Posts
Turn the mixure screws out about a 1/4 turn, also verify the idle speed (slide heights) are not set too high. They often have the idle spped too high for the RER to function better, but it also makes them more prone to this condition you describe. 1500-1700 with mixure set correct and it should idle back down quickly or hang for a second or two, and hang for a few more seconds when it good and hot after a hard pull.
 

·
Registered
Joined
·
471 Posts
mine did the same unill i backed out the fule screws 1/2 turn
 
1 - 5 of 5 Posts
Top