Ski-Doo Snowmobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter · #1 ·
was wondering if any one could help me out? every time i put gas in my sled when i remove the gas cap there is alot of air pressure comeing out of the tank. i was ridding tug hill tues. night i had about 60 miles on a fresh fill up and machine just died like i was out of gas, flipped the choke on sled started and died again so i figured i was out of gas and what a pig. my wife towed me back to the Montegue where we had just come from and i filled up. to my surprize the sled only took 5.6 gallons so that means i still had roughly 5 gallons of fuel left. my thinking is i have a vent line plugged. to any one that knows where is it and how do i fix it. any help would be greatly appreciated. i've ridden skidoo for 30+ years but i'm new to the rev and still pretty green but i'm learning!!!


thanks
mike
 

·
Registered
Joined
·
8,113 Posts
there is a vent hose with a check valve that is routed out the top of the tank and up near the spot there where the steering column meets the frame...

having said that, all revs have pressurized tanks many even make a moaning sound when you sit on them and they do not run out of fuel becasue of it... to hear air escape when opening the cap is normal...

there were issues with older revs, my 04 had a fuel pickup that got hung up on a tank ballast so it was sitting too high and would only allow me to get 6 or so useful gallons... when they reseated the pickup I got it all...

do a search LOTS of info here....
 

·
The 02 REVOLUTION
Joined
·
3,892 Posts
The fuel line pickup in the tank is your problem. You'll have to reposition it. The pressure problem could be a defective vent check valve or installed backwards, possibly from the factory? I beleive they had a few sleds out in 03 that had valves installed incorrectly from the factory.
 

·
Registered
Joined
·
194 Posts
709 000 059 is the vented gas cap from an Outlander 400 ATV, thats what I put on mine. The one off the 05 440 is the same except it says "Premix Only 40:1" or whatever on it and I have oil inject on my 800sdi as you would expect. I put it on because my 04 600sdi was really bad for putting right up and making a really annoying buzzing sound when I shut the sled off. The 440s all come with them so that the tank has not chance of pulling a vacum and causing a lean condition.
 
1 - 9 of 9 Posts
Top