Ski-Doo Snowmobiles Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Working on a buddy's 800 and need advise.He stuck the mag side piston after only 5 miles this year.We tore it down and replaced piston,ring,wrist pin and bearing and base gasket.Cleaned carbs.Starts fin but after about a minute the idle starts to climb.Throw the choke on and it settles back down.Take off the choke and it is fine for about a minute again and then starts to climb back up.Mag side cyl. seems to be slightly hotter than pto side.Everything seems to point to mag side crank seal or fuel delivery problem.Anyone have the same problem or any other ideas?Thanks for any help.Sled has just over 1000 miles.
 

·
Registered
Joined
·
1,226 Posts
poorboy said:
Working on a buddy's 800 and need advise.He stuck the mag side piston after only 5 miles this year.We tore it down and replaced piston,ring,wrist pin and bearing and base gasket.Cleaned carbs.Starts fin but after about a minute the idle starts to climb.Throw the choke on and it settles back down.Take off the choke and it is fine for about a minute again and then starts to climb back up.Mag side cyl. seems to be slightly hotter than pto side.Everything seems to point to mag side crank seal or fuel delivery problem.Anyone have the same problem or any other ideas?Thanks for any help.Sled has just over 1000 miles.
[snapback]266511[/snapback]​
my02 mxzx 800 had to have rings and crank seals replaced 1400 miles.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top