Ski-Doo Snowmobiles Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Skandic / Expedition
    I have a 2015 Skandic 550 with about 700 miles on it. I went out to start it the other day...choked it and it fired up. Then died after about 15 seconds. Started again and it ran for about 2 more seconds then sputtered out. Wouldn't start again after that, just cranked. It's been very cold...
  2. REV Chassis - Performance and Trail Models
    Went north for the weekend and started sled on saturday morning, notice oil light was on and tach not working but ran fine also headlights did not work, let sled sit all day and returned from all day ride and started it. Ran fine and everything worked. loaded sled inside trailer for the night...
  3. Vintage Ski Doo's
    Hello all, This is my first post on Doo talk! I am having some problems with my 1977 Ski doo Olympic. It will only fire up on fuel supplied by the primer and will then die. It will stay running if I keep pumping the primer. I have been doing a lot of work on this sled. Here is what I have...
  4. MXZ / Legend / Summit / Grand Touring / Formula
    Hi everyone, I have been lurking on this forum for a day and a half, and found some good stuff. Unfortunately, not enough to get this newly acquired 2002 MXZ 700 Olympic Edition sled to run! Background: 52xx miles. Previous history unknown. It is a friends sled, he has had it for 3 years, and...
  5. MXZ / Legend / Summit / Grand Touring / Formula
    I noticed one of my rave valve caps in sticking out further than the other. What do I need to do? I know this is the least of my worries since my sled lost spark and I have no idea why. I had a new stator put in it and it fired up and died right away. Now no spark again. Also, is the kill...
1-5 of 5 Results
Top