Ski-Doo Snowmobiles Forum banner
stator
1-20 of 77 Results
  1. Freestyle / Legend / Tundra / Expedition Sport
    I have no spark on my '92 tundra LT. I have tested the coil and it is all good. I am testing the stator but I don't know the specs for the ohms/resistance on the stator. Anyone have any suggestions? Also, if the stator turns out to be good, I guess I'll have to buy a new cdi.
  2. Skandic / Expedition
    So I'm working on a 1996 Rotax 377 in a Scandic. Ducati ignition system. So the engine abruptly died. No spark. Measured stator and trigger, all values were within spec. So ordered a new coil/CDI (SPI brand). Got a weak spark, now and then, so no success. Because the sled was outdoors when I...
  3. MXZ / Legend / Summit / Grand Touring / Formula
    I have a 2003 Summit Adrenaline 600 HO with manual start and RER. I has about 4,000 miles on it and I've only owned it for 6 weeks. I'm looking for any help in testing my stator. I've read countless posts on this forum and watched many youtube videos. I'm fairly mechanically inclined so the...
  4. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    I have a 08 MXZ X 800r power-Tek. It will not charge the battery to more then 11.5v. The sled will pull start and run fine. If I disconnect the battery and put my meter on it the voltage jumps around, I am kind of surprised it will run. I have a shop manual and went through all the checks...
  5. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    I have a 2012 600 etec, started it yesterday (temp about 2 degrees out) and was running great for first couple miles ( have 80 on it this season is all), but after idling for a couple minutes on side of trail check engine light came on. Shut it off and restarted it, light stayed off but noticed...
  6. REV-GEN 4 - Summit/Freeride/ 850 Turbo
    Just curious if anyone here has any experience with code P1562. My 2017 Summit 850 ran fine all day yesterday, stopped at a cabin, when going to leave I fired it up and noticed the headlights surging/flickering, and rpm slightly surging with it. Check engine came on and pulled code P1562. Rode...
  7. MXZ / Legend / Summit / Grand Touring / Formula
    Hey guys brand new to the forum so any guidance would be awesome. I've got a 2003 mxz550f my dad and I are working on and I can't for the life of me figure out what's going on. We bought it partially disassembled because the previous owner didn't want to pay for the repairs that the shop found...
  8. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    2009 MXZ TNT 600 ETEC Original issue was sled shut off during riding and could not get it to start, took it into the dealership and a few weeks of them not knowing what was wrong they call me and tell me it was just the spark plug wires were bad and grounding out. So I picked up the sled and...
  9. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    4800 miles, 2016 Renegade Enduro 800R etec, just stopped. Gauges blank. Only thing that works is 12V starter and fuel pump. Pulled apart, 0.9 ohm on each stator coil, no cross resistance, and 20Vac after about half a second of cranking. Fuel pump is working, pulled fuel line. Fuel going into ECM...
  10. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Need some help! Last spring when I put my 2011 Rev XP 800 etec Renegade away, I used the summarization feature, removed the belt, put on my battery maintainer and put it on the stand. I rebuilt the primary clutch, put new hyfax on, couple idler wheels during the summer. Winter is nearing so I...
  11. Vintage Ski Doo's
    I have a 95 ski-doo touring SLE that I am trying to diagnose whether I have bad CDI, voltage regulator or maybe stator. While riding I lost lights. Turned machine off to check bulb which was fine. Had a hard time restarting - got it going and got out of the bush, but ran rough as if firing...
  12. Vintage Ski Doo's
    Can anyone here help my diagnose a faulty stator? Mine seems to check out fine when tested with an OHM meter on the generator side but wont produce any light thru the lighting coil. Does the lighting coil have anything to do with igniting the generator? I had the sled running several times...
  13. MXZ / Legend / Summit / Grand Touring / Formula
    Hey Guys, Having an issue with this sled. Engine runs great, starts fine, electrical used to flicker when the sled got hot after riding for a bit and then it would shut off completely so i was riding home in the dark. Only seemed to happen when the sled got hot. Now i can start the sled fine...
  14. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Hey all, Wanted to get your opinions from past experiences. So we were up in the UP last weekend when a friend's sled (my old sled) started having 4 beeps and turning itself off. It did this over the course of 2 rides/days. Once just before we got back to the cabin Saturday night and then...
  15. REV Chassis - Performance and Trail Models
    Hey guys. Sudden new issue started yesterday. I'll start from beginning..... This is non electric start machine. Battery/capacitor setup. 8800 miles on rebuild. (Threw a rock through heat exchanger when new....almost made it home! Burned down) Purchased a new GEL battery 5 weeks ago. Ran great...
  16. Vintage Ski Doo's
    Hey guys, Wanting to change over the ignition in my 300SM TNT from points to CDI ignition Has anyone done this and what kind of stator will work in this sled. We are fine tuning this sled for Ice Oval racing
  17. REV Chassis - Performance and Trail Models
    Probing for feedback, I've had a few people tell me it's the coil. My 06 800cc Adrenaline is acting strange, ran fine all season up till a week ago. I get it warmed up an go ripp it, a minute or so later it runs like on one cylinder. I shut it down wait ten mins it will run great for a minute...
  18. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Hello everyone! I'm struggling with my Freeride.. Ended up being towed by other Skidoo. I'm pretty sure my stator is damaged someway! I put link to the youtube video to show you what really happened. It didn't even start anymore as you can see. Sled gives good spark to both cylinders. Minutes...
  19. REV Chassis - Performance and Trail Models
    I just put a full top end in my 2005 500ss. After torquing everything to spec and buttoning everything up theres no spark when i pull it over. Last year i was riding and stopped and when i went to start it again it didnt have any spark but after i got home it did. what could it be? MPEM...
  20. MXZ / Legend / Summit / Grand Touring / Formula
    Hi everyone... I read all the posts on this topic, I just hope I am missing something. . I bought this sled not working, and now I understand why the guy before me didnt want it... No spark. Here is what I have tested. Tested Tether, key and kill switch, all are working correctly. Coils -...
1-20 of 77 Results
Top